Page MenuHomePhabricator

When opening reference dialog from the MWGeneralReferenceDialog the cursor "insists" on being on the general document surface rather than the dialog inputs
Closed, ResolvedPublic1 Story Points

Description

To duplicate:

  1. Open VE
  2. Click on Citoid inspector
  3. Click on "full citation dialog" link
  4. Choose a non-basic reference, like Journal
  5. Try to type in the fields

Observed -- the cursor goes back to the general document CE surface.

Bisected to VE core update ce9bde489e01f6b2c166a2fc0df616b0315dc8c3

And specifically the fix to "Re-apply selection when ContentBranchNode changes" - facbde556a345d7b55e7ea092112bf77d8f5415e

Event Timeline

Mooeypoo created this task.Apr 4 2015, 12:42 AM
Mooeypoo raised the priority of this task from to Unbreak Now!.
Mooeypoo updated the task description. (Show Details)
Mooeypoo added a project: VisualEditor.
Mooeypoo added a subscriber: Mooeypoo.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 4 2015, 12:42 AM
Mooeypoo assigned this task to Esanders.Apr 4 2015, 12:43 AM

The fix is not the cause, it just closed a loop-hole. When GeneralReferenceDialog changes to one of the specific dialogs it closes itself, then opens the next window using the window manager directly, bypassing WindowAction, which makes sure the surface is properly de-activated. In this case closing the general dialog re-activates the surface, but improperly opening the next window doesn't de-activate it again.

Change 202412 had a related patch set uploaded (by Esanders):
Fix opening of specific reference dialog

https://gerrit.wikimedia.org/r/202412

Jdforrester-WMF closed this task as Resolved.Apr 7 2015, 3:37 PM
Jdforrester-WMF lowered the priority of this task from Unbreak Now! to High.
Jdforrester-WMF set Security to None.
Jdforrester-WMF edited a custom field.
Jdforrester-WMF moved this task from Nominated to Done on the VisualEditor 2014/15 Q4 blockers board.

Change 202412 merged by jenkins-bot:
Fix opening of specific reference dialog

https://gerrit.wikimedia.org/r/202412