Page MenuHomePhabricator

Bugzilla read-only clone to provide alternate search interface for bugzilla database
Closed, ResolvedPublic

Description

https://old-bugzilla.wikimedia.org/query.cgi?format=advanced saves me multiple hours of work every week due to its higher precision at finding reports. If old-bugzilla is decommissioned, I'll need the database and a search interface elsewhere. I am willing to do the setup work, presumably on a wmflabs.org domain (though the degradation in service would not be nice).

Any implementation proposal, other than setting up a bugzilla clone?


http://bugs.wmflabs.org created

TODO:

  • In the announcehtml add a prominent link to the original bugzilla.wikimedia.org URL hoping in redirects: use $ENV{'REQUEST_URI'}??
  • Allow login or other way to easily list your own votes
  • Make full quips, reports/charts and whatever world-readable
  • Think of /robots.txt
  • Set incoming links for stuff not available elsewhere

WONTFIX?

  • Apply skin and other aesthetic modifications
  • Other content like attachments; fix Can't locate PatchReader/Raw.pm`
  • Restore original email addresses and autocompletion thereof to ease searching

The operations/puppet roles don't seem useful, too much to cherry-pick; maybe an earlier functioning version exists.

Event Timeline

Nemo_bis created this task.Apr 7 2015, 8:09 AM
Nemo_bis raised the priority of this task from to Normal.
Nemo_bis updated the task description. (Show Details)
Nemo_bis added subscribers: Krenair, Qgil, Aklapper and 3 others.
Aklapper raised the priority of this task from Normal to Needs Triage.Apr 7 2015, 9:31 AM

Could you document some of the concrete searches here that you exclusively use old-bugzilla for?

I use everything at https://old-bugzilla.wikimedia.org/query.cgi?format=advanced : mostly search by summary, product, components, comment, people, severity, regex search, boolean operators, Blocks.

Some examples for you: https://paste.debian.net/hidden/b304b0f6/

Bugzilla's search is more powerful than Phabricator's. The question is how often this power is actually needed and by how many users. :)

I'm interested in important and common query types that are entirely not possible in Phabricator, apart from those queries related to stuff that we decided to not migrate anyway (severity, votes, aliases, etc).
From a very quick look (won't go throw each of >500 queries), many things look totally possible in Phabricator to me.

As time goes, the technical superiority of Bugzilla's search will be hampered by the fact that a bigger percentage of reports will be found only in Phabricator, so I'm not sure how useful this feature will be by the time old-bugzilla is decommissioned.

Aklapper triaged this task as Lowest priority.Apr 7 2015, 1:57 PM
Aklapper removed a project: acl*sre-team.
Aklapper set Security to None.

An alternative search interface could be provided using the database dump however it will not be a priority at all for the ops team to provide an interface for this. From the views above, I don't see it realistically being a priority for ECT either which leaves it up to a volunteer.

Any help from people is of course welcome but is blocked by the database dump being available currently.

As time goes, the technical superiority of Bugzilla's search will be hampered by the fact that a bigger percentage of reports will be found only in Phabricator

Sure. Given
https://old-bugzilla.wikimedia.org/reports.cgi?product=MediaWiki&datasets=UNCONFIRMED&datasets=NEW&datasets=ASSIGNED&datasets=PATCH_TO_REVIEW&datasets=REOPENED&datasets=RESOLVED&datasets=VERIFIED&datasets=CLOSED that can't happen before early 2017, or more realistically 2024.

which leaves it up to a volunteer.

That's sad, but I assumed so since comment 0, and volunteered; I estimate that anything costing me less than 1 month full time work will pay back the investment to me personally.

I frequently use old-bz for searching, so something like this would be fantastic.

I am still interested in specific examples of searches which are *not* possible in Phabricator and why these queries are specifically important for your bug/task related workflows (given that the search results in old-bz are from a few months ago).

Andre, I gave hundreds of specific examples. :) If you want a full list of specific examples, you might want to compare the documentation of Bugzilla's search feature and the documentation of Phabricator's search feature, plus the reports about them, and make a list. I've already spent enough volunteer time pointing out the deficiencies of Phabricator search, I don't think it's a good investment to duplicate this effort.

This will be possible when the dump is released and there will also be plenty of time for a replacement to bugzilla to be made before bugzilla goes. So unless I'm missing anything, this is purely waiting on the dump then to be made right?

This is now possible.

This is now possible.

Therefore removed it being a blocker for the parent task.

Restricted Application added a subscriber: scfc. · View Herald TranscriptJun 16 2015, 12:51 PM
Nemo_bis claimed this task.Jul 14 2015, 9:10 AM
Nemo_bis raised the priority of this task from Lowest to Normal.
Nemo_bis updated the task description. (Show Details)
Nemo_bis added subscribers: MZMcBride, Peachey88.
Nemo_bis updated the task description. (Show Details)Jul 14 2015, 9:15 AM
Nemo_bis removed a project: Phabricator.
Nemo_bis updated the task description. (Show Details)Jul 14 2015, 9:19 AM
Nemo_bis renamed this task from Provide alternate search interface for bugzilla database to Bugzilla clone to provide alternate search interface for bugzilla database.Jul 14 2015, 9:23 AM
Nemo_bis renamed this task from Bugzilla clone to provide alternate search interface for bugzilla database to Bugzilla read-only clone to provide alternate search interface for bugzilla database.Jul 14 2015, 9:54 AM
Nemo_bis updated the task description. (Show Details)
Nemo_bis updated the task description. (Show Details)Jul 14 2015, 10:03 AM
Nemo_bis updated the task description. (Show Details)

What is left to do in this task?
http://bugs.wmflabs.org/ is up and running. (and helpful for certain user-account related queries, thanks for setting it up!)

Dzahn removed a subscriber: Dzahn.Feb 16 2016, 6:03 PM
Peachey88 closed this task as Resolved.EditedMay 31 2016, 3:55 AM

What is left to do in this task?
http://bugs.wmflabs.org/ is up and running. (and helpful for certain user-account related queries, thanks for setting it up!)

Closing as done (and no reply since Feb)

Nemo_bis updated the task description. (Show Details)Jul 31 2016, 7:28 AM
Nemo_bis updated the task description. (Show Details)Jul 31 2016, 7:30 AM