Page MenuHomePhabricator

On iOS 8.3 iPhone 5c in Private mode Safari, sometimes dragging/flicking doesn't scroll in modals
Closed, ResolvedPublic

Description

I've noticed that in some modal style screens on the Wikipedia mobile web that dragging/flicking doesn't reliably result in scrolling. Usually, if I try, say, 5+ times, it eventually activates scrolling, though.

Two places where I've observed this are as follows:

(1) Tapping the edit pencil. I tapped the edit pencil on the lead section of "Joe Beef (restraurant)" while not logged in on the stable channel. I see the anon editing warning, and the first 2.5 buttons below it, but regular dragging/flicking is spotty.

(2) Attempting to scroll the results list in search in alpha / experimental mode. When I was getting a list of results I think from the auto fulltext mode last week or the week before, although there were obviously more results than could fill the screen, dragging the list didn't do anything. It seems at least this morning that it's in prefix mode on alpha / experimental, so I'm unable to reproduce.

The edit issue I've only seen on iOS 8.3, because I've only tried anonymous editing on 8.3.

The alpha / experimental symptom was present on iOS 8.2 (8.2, not sure about 8.3 - just upgraded!) on the 5c device as well. Unsure if it's related to Private mode browsing at all, but wanted to clarify in case there's something strange with LocalStorage or what have you.

Event Timeline

dr0ptp4kt created this task.Apr 9 2015, 3:18 PM
dr0ptp4kt raised the priority of this task from to Needs Triage.
dr0ptp4kt updated the task description. (Show Details)
dr0ptp4kt added a project: Readers-Web-Backlog.
dr0ptp4kt moved this task to Incoming on the Readers-Web-Backlog board.
dr0ptp4kt added a subscriber: dr0ptp4kt.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 9 2015, 3:18 PM
phuedx added a subscriber: phuedx.Apr 10 2015, 5:25 PM

This is a fire bucket ticket.

Fire bucket ticket..? Is this still an issue? We had some issues with scroll events that this sounds related to - see T93988

This might be somewhat related to T95465. During my research into the bug I've found that Apple tend to break things with new iOS Safari releases. A lot. Including scrolling!

Jdlrobson set Security to None.
Jdlrobson moved this task from Incoming to 2015-16 Q3 on the Readers-Web-Backlog board.
kaldari closed this task as Resolved.Apr 30 2015, 10:49 PM

Both of these issues appear to have been fixed by https://gerrit.wikimedia.org/r/#/c/207705/.