Page MenuHomePhabricator

Citoid Syntaxerror on beta cluster
Closed, ResolvedPublic

Description

I found in the /data/project/syslog/syslog file that the citoid service kept being respawned.

On deployment-sca01.eqiad.wmflabs in /var/log/upstart/citoid.log there is a bunch of:

etc/citoid/config.yaml:1
(function (exports, require, module, __filename, __dirname) { # Number of work
                                                              ^
SyntaxError: Unexpected token ILLEGAL
    at Module._compile (module.js:439:25)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/srv/deployment/citoid/deploy/src/server.js:27:20)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)

Event Timeline

hashar created this task.Apr 9 2015, 8:48 PM
hashar raised the priority of this task from to High.
hashar updated the task description. (Show Details)
hashar added a subscriber: hashar.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 9 2015, 8:48 PM
hashar added a comment.Apr 9 2015, 8:50 PM

/etc/citoid/config.yaml is definitely a YAML file but somehow it is being loaded as a javascript file :/

mobrovac claimed this task.Apr 9 2015, 9:08 PM
mobrovac added a subscriber: mobrovac.

Ah, yeah, my bad. We switched to a new config format but haven't updated the deployment-prep repo. Will do so tomorrow.

Merci beaucoup for noticing and letting us know @hashar !

greg set Security to None.
greg added a subscriber: greg.

Citoid is now up, but Zotero refuses to start on deployment-sca01. Investigating ...

After conducting some pillow talk with trebuchet, everything is in its place now. The issue is not completely resolved in that zotero runs on deployment-zotero01 while citoid is on deployment-sca01. This patch addresses that problem.

mobrovac moved this task from Backlog to Production on the Citoid board.Apr 10 2015, 9:16 AM

Change 203294 had a related patch set uploaded (by Mobrovac):
Citoid: Change Zotero's host for Beta

https://gerrit.wikimedia.org/r/203294

Change 203294 merged by Filippo Giunchedi:
Citoid: Change Zotero's host for Beta

https://gerrit.wikimedia.org/r/203294

mobrovac closed this task as Resolved.Apr 13 2015, 3:03 PM
mobrovac removed a project: Patch-For-Review.