Page MenuHomePhabricator

A6. Notifications resulting from a conversation in flow do not disappear after visiting the page.
Closed, ResolvedPublic2 Story Points

Description

Her's the scenario:

  1. Echo presented two message notifications in Amir Aharoni's talk page (using Echo)
  2. I clicked one of them and was transferred to the right thread.
  3. I still have two message notifications.

This happens repeatedly, with any number of messages.

Event Timeline

TomerA created this task.Apr 12 2015, 3:43 PM
TomerA updated the task description. (Show Details)
TomerA raised the priority of this task from to Needs Triage.
TomerA added subscribers: TomerA, Amire80, IKhitron.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 12 2015, 3:43 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

I don't have a bulletproof way to reproduce it - sometimes it happens to me and sometimes it doesn't. But I definitely experience something like this frequently in hewikipedia and in mediawiki.org.

Sorry if this a duplicate. I tried to search for something similar but the search engine is not very friendly.

I don't have a bulletproof way to reproduce it - sometimes it happens to me and sometimes it doesn't. But I definitely experience something like this frequently in hewikipedia and in mediawiki.org.

To me this happens more often than not. I would even risk to say that it happens every time (with messages, not with other notifications).

I saw this regularly, in about 40% of cases.

If this only depends on which link you click, it's a duplicate of T85064: S12. Flow Notifications are not marked as read by visiting the Topic page (not yet deployed in production).

TomerA added a comment.EditedApr 13 2015, 8:17 AM

I am not sure this is the same as T85064. The description of T85064 says: "If I go to the Board itself, then the Notification '''is''' marked as read". I might get the terminology wrong, but I don't think this happens for me.

I've received an echo notification due to this reply: [https://he.wikipedia.org/w/index.php?title=%D7%A0%D7%95%D7%A9%D7%90:Sfblpywbj7468pfk&topic_showPostId=sfd4psgibjpi9hno#flow-post-sfd4psgibjpi9hno]. Clicking it leads me to [https://he.wikipedia.org/wiki/%D7%A0%D7%95%D7%A9%D7%90:Sfblpywbj7468pfk this] page. Notification is still there.

When I click the link to Amir's talk page (i.e., 'the board', right?) notification is still there.

So, unlike in the case of T85064, the notification doesn't disappear either way.

I am not sure this is the same as T85064. The description of T85064 says: "If I go to the Board itself, then the Notification '''is''' marked as read". I might get the terminology wrong, but I don't think this happens for me.

I've received an echo notification due to this reply: [https://he.wikipedia.org/w/index.php?title=%D7%A0%D7%95%D7%A9%D7%90:Sfblpywbj7468pfk&topic_showPostId=sfd4psgibjpi9hno#flow-post-sfd4psgibjpi9hno]. Clicking it leads me to [https://he.wikipedia.org/wiki/%D7%A0%D7%95%D7%A9%D7%90:Sfblpywbj7468pfk this] page. Notification is still there.

When I click the link to Amir's talk page (i.e., 'the board', right?) notification is still there.

So, unlike in the case of T85064, the notification doesn't disappear either way.

Different notifications are 'auto-dismissed' from different places. A new-topic notification is dismissed by visiting the board, but not the topic. A reply notification is dismissed by visiting the topic, but not the board. This is being resolved for the case of new-topic in the other ticket, I don't think we've yet have a plan for autodismissing topic level notifications from the board.

I am not sure this is the same as T85064. The description of T85064 says: "If I go to the Board itself, then the Notification '''is''' marked as read". I might get the terminology wrong, but I don't think this happens for me.

I've received an echo notification due to this reply: [https://he.wikipedia.org/w/index.php?title=%D7%A0%D7%95%D7%A9%D7%90:Sfblpywbj7468pfk&topic_showPostId=sfd4psgibjpi9hno#flow-post-sfd4psgibjpi9hno]. Clicking it leads me to [https://he.wikipedia.org/wiki/%D7%A0%D7%95%D7%A9%D7%90:Sfblpywbj7468pfk this] page. Notification is still there.

When I click the link to Amir's talk page (i.e., 'the board', right?) notification is still there.

So, unlike in the case of T85064, the notification doesn't disappear either way.

Different notifications are 'auto-dismissed' from different places. A new-topic notification is dismissed by visiting the board, but not the topic. A reply notification is dismissed by visiting the topic, but not the board. This is being resolved for the case of new-topic in the other ticket, I don't think we've yet have a plan for autodismissing topic level notifications from the board.

That's the bug I'm reporting - a reply notification is not dismissed at all (even after visiting the topic).

EBernhardson triaged this task as High priority.Apr 13 2015, 5:50 PM
DannyH set Security to None.Apr 15 2015, 6:33 PM
DannyH edited a custom field.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 22 2015, 7:08 PM
DannyH renamed this task from Notifications resulting from a conversation in flow do not disappear after visiting the page. to A6. Notifications resulting from a conversation in flow do not disappear after visiting the page. .Apr 22 2015, 8:04 PM

Judging from TomerA's description of the problem ("Clicking it leads me to [topic page] page. Notification is still there."), I'm pretty sure https://gerrit.wikimedia.org/r/#/c/197075/2/includes/Notifications/Controller.php will fix this.

We're waiting for a schema change (T94427: Perform schema change to echo_target_page changing from a 1 to 1 mapping between pages and user/notification to a 1 to many.) first, then we can merge this.

Change 197075 had a related patch set uploaded (by Matthias Mullie):
Mark new topic notifications read from both board and topic pages

https://gerrit.wikimedia.org/r/197075

Change 197075 merged by jenkins-bot:
Mark new topic notifications read from both board and topic pages

https://gerrit.wikimedia.org/r/197075

DannyH closed this task as Resolved.Jun 2 2015, 4:24 PM
DannyH moved this task from QA Review to Done on the Collaboration-Team-Sprint-B-2015-05-20 board.
DannyH added a subscriber: DannyH.