Page MenuHomePhabricator

iOS: Sprint 55 Release (4.1.3)
Closed, ResolvedPublic

Description

This is for tracking and performing the releasing stuff at the following links.

See iOS release process for process documentation.
Keep iOS release status and history up to date.

Release version: 4.1.3.96
Release tag: 4.1.3.96
Release SHA1: 08f301ed112e59eea9f0f4b393031b004281b3e9
App Store Wikipedia Mobile Submission Date: 5/5/15
App Store Wikipedia Mobile Approval Date: May 13
App Store Wikipedia Mobile Release Date: May 13th
Blog post: None
Tweet:
Facebook post:
Regression Testing URL:

  • Point current status at this card
  • Prior sprint's work Done
  • Add roadmap and notice tags
  • TestFlight Wikipedia Beta rev version number if necessary (can take 3 days for approval)
  • TestFlight Wikipedia Beta internal
  • TestFlight Wikipedia Beta external
  • mobile-l about Wikipedia Beta external
  • Upload release candidate (RC) to "Wikipedia Mobile" App Store record
  • Distribute "Wikipedia Mobile" RC for internal testing
  • Procure verbiage for What's New and Description, if appropriate
  • Procure updated screenshots, if appropriate
  • Submit RC for Apple review with automatic release disabled.
  • not necessary TestFlight Wikipedia Mobile rev version number if necessary (can take 3 days for approval)
  • Regression testing by TSG, if required
  • Perform upgrade smoke tests from current App Store version to new "Wikipedia Mobile" release candidate
  • Communications engaged
  • no blockers Blockers swarmed, if necessary
  • Product manager signoff
  • Released to App Store (NOT on a Friday!)
  • Update central mobile release history once released
  • Update HockeyApp console to mark build as released once released
  • Blog post, if appropriate (n/a)
  • mobile-l post about App Store release
  • Tweet (sent request to comms)
  • Facebook (sent request to comms)

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 13 2015, 11:02 PM
dr0ptp4kt renamed this task from Releasing to Releasing Sprint 54 Work Product.Apr 13 2015, 11:03 PM
dr0ptp4kt set Security to None.
dr0ptp4kt updated the task description. (Show Details)Apr 13 2015, 11:24 PM
dr0ptp4kt updated the task description. (Show Details)
dr0ptp4kt updated the task description. (Show Details)Apr 13 2015, 11:26 PM

Note, I still need to clean up the checklist some.

dr0ptp4kt updated the task description. (Show Details)Apr 14 2015, 4:56 PM
KLans_WMF triaged this task as Medium priority.Apr 20 2015, 9:47 PM
KLans_WMF moved this task from Needs Triage to In Development on the Wikipedia-iOS-App-Backlog board.
dr0ptp4kt renamed this task from Releasing Sprint 54 Work Product to Releasing Sprint 55 Work Product.Apr 24 2015, 6:06 PM
dr0ptp4kt reassigned this task from dr0ptp4kt to Fjalapeno.Apr 28 2015, 10:07 PM
dr0ptp4kt moved this task from To Do to Doing on the Mobile-App-Sprint-56-iOS board.
Fjalapeno renamed this task from Releasing Sprint 55 Work Product to Sprint 55 Releasing.Apr 29 2015, 6:01 PM
Fjalapeno renamed this task from Sprint 55 Releasing to Sprint 55 Release.
Fjalapeno updated the task description. (Show Details)Apr 29 2015, 6:33 PM
Fjalapeno updated the task description. (Show Details)Apr 29 2015, 6:35 PM
Fjalapeno updated the task description. (Show Details)Apr 30 2015, 4:10 PM
BGerstle-WMF updated the task description. (Show Details)
Restricted Application added a project: Notice. · View Herald TranscriptMay 1 2015, 4:57 PM
greg renamed this task from Sprint 55 Release to iOS: Sprint 55 Release.May 1 2015, 4:57 PM
greg added a subscriber: greg.May 1 2015, 5:23 PM

Notes:

  1. Use the Roadmap project for things like this
  2. Was there a releng team ask here, or just an FYI?
  3. When you have one, please put a date in the task title and/or move it to the appropriate column in the Roadmap workboard
  4. yay releases

@Fjalapeno mind getting the ball rolling on release notes/description?

@greg just an FYI for you. Will get release notes & estimated date from team and report back here and add to the Roadmap project.

BGerstle-WMF updated the task description. (Show Details)
BGerstle-WMF updated the task description. (Show Details)
Fjalapeno updated the task description. (Show Details)May 4 2015, 4:12 PM
BGerstle-WMF updated the task description. (Show Details)
Fjalapeno updated the task description. (Show Details)May 5 2015, 10:56 PM
gpaumier moved this task from Backlog to Triaged on the Notice board.May 6 2015, 8:34 PM
Etonkovidova updated the task description. (Show Details)May 6 2015, 9:36 PM
BGerstle-WMF renamed this task from iOS: Sprint 55 Release to iOS: Sprint 55 Release (4.1.3).May 6 2015, 9:38 PM
BGerstle-WMF updated the task description. (Show Details)
BGerstle-WMF moved this task from Unscheduled to This week: May 11-15 on the Roadmap board.
BGerstle-WMF moved this task from This week: May 11-15 to Unscheduled on the Roadmap board.
greg moved this task from Unscheduled to This week: May 11-15 on the Roadmap board.May 6 2015, 9:58 PM

@greg the update is likely to go live next week, but we're still wrangling platform leads to sign off. just to be sure, you don't see anything missing on your end from this checklist in terms of things we should be verifying with you?

Fjalapeno updated the task description. (Show Details)May 7 2015, 6:10 PM
Fjalapeno updated the task description. (Show Details)

@Etonkovidova since it got lost between both us editing the card, would you mind commenting that you signed off on this build? just to remove any ambiguity

Signed off by Design.

Notes:
All interface related items have been separately signed off.
We have not done aggregate build testing (testing all the features as part of one consolidated build), but that should be ok.

Fjalapeno updated the task description. (Show Details)May 11 2015, 4:48 PM

I'm signing off on this release. @Fjalapeno can you +/- 1?

@BGerstle-WMF I'm just going to remove those check boxes… at the last release meeting we decided that sign off is implicit (The train is in motion - you need to pull the cord to stop it)

Fjalapeno updated the task description. (Show Details)May 11 2015, 6:03 PM

App store review times are up to 9 days right now…

http://appreviewtimes.com

Adjusting our release date accordingly.

Fjalapeno updated the task description. (Show Details)May 12 2015, 3:04 PM

App just went into review!

Fjalapeno updated the task description. (Show Details)May 13 2015, 4:40 PM
Fjalapeno updated the task description. (Show Details)
Fjalapeno updated the task description. (Show Details)May 13 2015, 5:02 PM
Fjalapeno updated the task description. (Show Details)May 13 2015, 5:07 PM
BGerstle-WMF moved this task from Done to Doing on the Mobile-App-Sprint-57-iOS board.
Fjalapeno updated the task description. (Show Details)May 13 2015, 9:45 PM

@Fjalapeno this worth tweeting FB posting?

Fjalapeno updated the task description. (Show Details)May 13 2015, 11:31 PM
Fjalapeno moved this task from Doing to Design Signoff on the Mobile-App-Sprint-57-iOS board.
Fjalapeno moved this task from Design Signoff to Done on the Mobile-App-Sprint-57-iOS board.
greg moved this task from This week: May 11-15 to May 18-22 on the Roadmap board.May 16 2015, 5:30 AM
greg moved this task from May 18-22 to This week: May 11-15 on the Roadmap board.May 16 2015, 5:32 AM
gpaumier moved this task from Triaged to Archive on the Notice board.May 29 2015, 8:21 PM
Fjalapeno closed this task as Resolved.Jul 3 2015, 5:48 PM