Page MenuHomePhabricator

C7. Flow notification links are broken in emails
Closed, ResolvedPublic2 Story Points

Description

The last emails I received for from Flow looked like

https://www.mediawiki.org/w/index.php?title=Topic:Sexu2st74jdned37&topic_showPostId=sf7oy7og92pbs67a&fromnotif=1&action=edit&redlink=1

which is not working (they are 302 redirections to the topic pages, without color markers for unread posts) and required me to click on the web notification in order to see what was changed:

https://www.mediawiki.org/w/index.php?title=Topic:Sexu2st74jdned37&topic_showPostId=sf7oy7og92pbs67a&fromnotif=1#flow-post-sf7oy7og92pbs67a


As part of this fix, this redirect should only drop the action=edit (and maybe redlink) parameters, not the rest.

Event Timeline

Ltrlg created this task.Apr 15 2015, 4:55 PM
Ltrlg raised the priority of this task from to Needs Triage.
Ltrlg updated the task description. (Show Details)
Ltrlg added a project: StructuredDiscussions.
Ltrlg added a subscriber: Ltrlg.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 15 2015, 4:55 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

This was broken by an RFC that was approved (and apparently merged) last week. There is a hook that allows us to say we 'opt in' to various parameters in the redirect.

The other half of fixing this will be adjusting Flow\UrlGenerator to ensure its now generating /wiki/* urls

I was thinking of RedirectSpecialArticleRedirectParams, which is not applicable (only applies to special pages). Also, T14619: Use article path URLs for editing, previewing skins, etc. is apparently not merged. So it's not clear what's going on here.

EBernhardson triaged this task as High priority.Apr 20 2015, 5:56 PM
DannyH set Security to None.Jun 3 2015, 6:23 PM
DannyH edited a custom field.

May have been caused by T95581: Flow board creations do not create entry in core's page and revision tables causing red links for existent topics. Apparently, action=edit on a Flow topic always causes redirecting to the view (dropping the parameters). As part of this fix, the parameters should not be dropped.

DannyH renamed this task from Flow notification links are broken in emails to C7. Flow notification links are broken in emails.Jun 3 2015, 7:14 PM

Change 217274 had a related patch set uploaded (by Matthias Mullie):
Make sure Topic:xyz pages exist() as soon as the topic is created

https://gerrit.wikimedia.org/r/217274

I'm unable to reproduce this on my end, so just to make sure:

  • What was the exect notification you recieved? New topic, reply, ...?
  • And was it bundled (daily/weekly digest) or email for an individual event?

Change 217462 had a related patch set uploaded (by Matthias Mullie):
Guarantee a correct known status for Linker::link

https://gerrit.wikimedia.org/r/217462

Change 217462 merged by jenkins-bot:
Guarantee a correct known status for Linker::link

https://gerrit.wikimedia.org/r/217462

Change 217274 abandoned by Matthias Mullie:
Make sure Topic:xyz pages exist() as soon as the topic is created

Reason:
I agree witgh YAGNI. I put up https://gerrit.wikimedia.org/r/#/c/218025/ to explain the insert order - if we ever want to change it, we can reconsider this problem, but having a fix "just in case" is pointless.

https://gerrit.wikimedia.org/r/217274

Is this task resolved / ready for sign-off now? All patches associated with it have either been merged or abandoned, so the "needs review" status is probably outdated.

Tested in betalabs: The link looks like this: href="https://en.wikipedia.beta.wmflabs.org/w/index.php?title=Topic:Sjal0evmt3cw5ugb&topic_showPostId=sjanlbo6r8r1h6qz&fromnotif=1#flow-post-sjanlbo6r8r1h6qz"

action=edit&redlink=1 are not present.

Note: For betalabs, change https to http to see the page.

Etonkovidova closed this task as Resolved.Jun 15 2015, 11:52 PM