Create Wikipedia Goan Konkani
Closed, ResolvedPublic

Description

The language committee and WMF Board have approved the creation of Wikipedia Goan Konkani.

Language code: gom
Site URL: gom.wikipedia.org
Project name: विकिपीडिया
Project namespace: विकिपीडिया
Project talk namespace:
Project logo: To be prepared, requested at https://meta.wikimedia.org/wiki/Requests_for_new_languages/Wikipedia_Konkani_2
Timezone: Asia/Kolkata

Local file uploads: disabled

Notes:

  1. Language code gom to fallback to gom-deva (Goan Konkani (Devanagari script))
  2. Request page: https://meta.wikimedia.org/wiki/Requests_for_new_languages/Wikipedia_Konkani_2
  3. Approval: https://lists.wikimedia.org/pipermail/langcom/2015-March/000173.html
  4. Translations https://translatewiki.net/w/i.php?title=Special:LanguageStats&language=gom-deva&group=core-0-mostused
  5. Translatewiki.net portal https://translatewiki.net/wiki/Portal:Gom
There are a very large number of changes, so older changes are hidden. Show Older Changes

@Glaisher No, but I'm trying to help to create the project as soon as possible. btw did I submit that patch?

aude added a subscriber: aude.Apr 24 2015, 11:47 AM

hmmm, we'll have to populate the sites table in order to get the wikibase stuff working, and update it also on wikidata.

https://wikitech.wikimedia.org/wiki/Add_a_wiki#Wikidata

whoever handles this, please poke me on irc if there are any questions or problems. or if preferred, I can take care of these things.

@Visdaviva Since we already have a patch with a link to the Commons file, to make things simple, if you want to upload a logo, please upload it on top of https://commons.wikimedia.org/wiki/File:Wikipedia-logo-v2-gom.svg and https://commons.wikimedia.org/wiki/File:Wikipedia-logo-v2-gom.png Thanks.

btw, patch https://gerrit.wikimedia.org/r/206083 must be merged first and pushed to wmf/1.26wmf2 branch of mediawiki.

@Glaisher done uploaded a newer version of the logo. Let me know if there is anything else that I could help with.

Elitre added a subscriber: Elitre.Apr 27 2015, 8:35 AM

Sanitarium is ready.

Not yet confirmed for labs replica views, but that need not block the wiki creation upstream.

Dzahn added a comment.Apr 29 2015, 1:38 AM

fwiw, i don't see a reason for the "we usually do all the configuration in one patch"-rule. why couldn't i just set the logo while on it without having to know the answer to all other config questions?

Dzahn removed a subscriber: Dzahn.Apr 29 2015, 1:38 AM
Ijon added a comment.Apr 29 2015, 6:01 AM

@Glaisher and everyone, here are the translations for Module and Module talk, contributed by Konkani editor Darshan:

"Module"- मापदंड

"Module talk"- मापदंड चर्चा

Change 207430 had a related patch set uploaded (by Mjbmr):
Add namespace aliases for gom-deva

https://gerrit.wikimedia.org/r/207430

since they *have* reached the threshold some time ago

Impossible, or the locale would have been exported, per https://translatewiki.net/wiki/Translating:MediaWiki .
Most of the activity was on 2015-03-15 or before and on that day gom-deva reached 15.48 %, not 18 %.

So before we create this wiki, we need those translations to be approved and deployed, right?

@Nemo_bis the Konkani community has already done 91% of the Mediawiki (most important messages) of this 80% were reviewed. See here https://translatewiki.net/w/i.php?title=Special:Translate&language=gom-deva&group=core-0-mostused&filter=translated&action=translate
While the community will take on localization sprints, are there any further important messages that should be prioritized? Would be helpful if a link to those messages is provided. Thanks!

So before we create this wiki, we need those translations to be approved and deployed, right?

Right.. but it'll only be deployed once the threshold has been reached and currently it's below it. (16%)

While the community will take on localization sprints, are there any further important messages that should be prioritized? Would be helpful if a link to those messages is provided. Thanks!

Once all the messages in mostused group is translated, it'll certainly be above the threshold for exporting to core.. Even if mostused is not 100%, other messages in core group can also be translated so that it can be above the threshold.

Change 207430 merged by Nikerabbit:
Add namespace aliases for gom-deva

https://gerrit.wikimedia.org/r/207430

Mjbmr added a comment.May 6 2015, 9:04 AM

@Nemo_bis @Glaisher I don't see any reason why you guys are waiting.

Apart from the fact that Glaisher and Nemo are not the people who can create the new wiki, it still does not seem wise to create a wiki whose language is still not exported, i.e. unknown to the software.

Mjbmr added a comment.May 6 2015, 11:02 PM

@MF-Warburg, I know they are not the people who can create the new wiki.

Well then why are you saying that they're waiting?

Mjbmr added a comment.May 6 2015, 11:04 PM

They know, and you not them.

Ijon added a comment.EditedMay 7 2015, 1:19 AM

I have encouraged the community to continue localization of messages to reach at least the threshold of 18% of MW core. It is up to 16.6% now, and more progress will follow in the coming days.

Dzahn added a subscriber: Dzahn.May 9 2015, 12:13 AM

I think the ops part in this was only adding it to DNS which is done and the mwconfig part is more -releng., or?

I was planning to just do the deployment side (config, maintenance script, etc.) once the language is actually imported to production. I don't think there's anything left for ops here.

Mjbmr added a comment.May 9 2015, 12:21 AM

There are a lot of other languages in MediaWiki that have less translations than Konkani language.

  • DNS - done by ops
  • Apache config - nothing to do for this particular task, since it's just a simple language addition
  • MW config - seems ready to go
  • Wait for translations to be sorted out
  • Actually sync the config and addWiki.php - I think we will need to schedule a deployment window?
Mjbmr added a comment.May 16 2015, 6:24 PM

The language should not be called "Konkani" should be called "Goan Konkani", what's the exact equal in native?

We have to merge gom-deva into gom and remove gom-latn since it's only written in Devanagari script.

Ijon added a comment.May 19 2015, 11:49 PM

The Konkani language is most certainly not written only in Devanagari, @Mjbmr, though Devanagari is the version with contributors at the moment, and the one we're working to get out of incubation.

@Ijon This is Goan Konkani (गोवा कोंकणी) and the official script in Goa is Devanagari.

http://www.thehindu.com/todays-paper/tp-national/tp-karnataka/goa-firm-on-implementation-of-official-language-act/article1346846.ece

Tbayer added a subscriber: Tbayer.May 26 2015, 8:27 PM

@Krenair: Translations for core exported from translatewiki.net. Language added with I384b3a14b232b346096066d678d84f7742b6d4c2

Ijon added a comment.May 29 2015, 11:09 PM

@Krenair -- Translations of core are now at 22%. I believe it's time to hit the buttob and move the wiki out of Incubator.

Krenair added a comment.EditedMay 29 2015, 11:23 PM
  • Before we can add Echo, we should figure out T100527 (or at least figure out how to copy the Echo schema over manually in x1 master). Note that the config patch currently includes the echowikis.dblist addition.
  • It sounds like this is still blocked on https://gerrit.wikimedia.org/r/#/c/206083/ ?
  • If this is done before MW 1.26wmf8 hits aawiki on Wednesday 3rd June, backport 10603817d3f4eca4f765a128b6721291a3fdf865 before running addWiki.php - although we might be able to get away with finding another s3 wiki which is already on wmf8?

Other than that, the process should look roughly like https://wikitech.wikimedia.org/w/index.php?title=Deployments&oldid=161080#deploycal-item-20150526T1600

Update: T100527 was figured out, and we no longer have to worry about that backport. So we're blocked on i18n setting up the language, and then this should be good to go.

So we're blocked on i18n setting up the language

What do you mean? There was a patch ready to merge which I +1, though it might have been messed up with since.

Krenair added a comment.EditedJun 14 2015, 1:27 PM

So we're blocked on i18n setting up the language

What do you mean? There was a patch ready to merge which I +1, though it might have been messed up with since.

I'm not interested in whether there's a patch "ready to merge" - you won't catch me merging it (+2 is only allowed for things that you're actually qualified to review - I am not for this patch, obviously), I'm only interested in when it arrives in WMF production, unless the language engineering team thinks it's unnecessary.

Which patch is it?

+1, but it would be nice if @siebrand or @Nikerabbit would double-check that the suffixes and the fallbacks are used correctly.

Change 206083 merged by jenkins-bot:
Add Goan Konkani Language

https://gerrit.wikimedia.org/r/206083

Change 218142 had a related patch set uploaded (by Mjbmr):
Add Goan Konkani Language

https://gerrit.wikimedia.org/r/218142

Change 218143 had a related patch set uploaded (by Mjbmr):
Add Goan Konkani Language

https://gerrit.wikimedia.org/r/218143

Mjbmr renamed this task from Create Wikipedia Konkani to Create Wikipedia Goan Konkani.Jun 14 2015, 6:11 PM
Mjbmr updated the task description. (Show Details)
Mjbmr assigned this task to Krenair.Jun 14 2015, 6:16 PM

Change 218143 merged by jenkins-bot:
Add Goan Konkani Language

https://gerrit.wikimedia.org/r/218143

Change 218142 merged by jenkins-bot:
Add Goan Konkani Language

https://gerrit.wikimedia.org/r/218142

Change 206300 merged by jenkins-bot:
Create Wikipedia Goan Konkani

https://gerrit.wikimedia.org/r/206300

Restricted Application added a subscriber: Matanya. · View Herald TranscriptJun 16 2015, 4:39 PM
Krenair closed this task as Resolved.Jun 16 2015, 4:46 PM

Done.

Mjbmr moved this task from To deploy to Done on the Wikimedia-Site-requests board.Jun 16 2015, 4:55 PM

Aren't the Latin script articles going to be copied too? As far as I can see, the LangCom approval doesn't say anything about being only for Devanagari. The localisations for gom-latn are 100% for 'MediaWiki (most important messages)' and 18% for 'MediaWiki (core)'.

Ijon added a comment.Jun 19 2015, 5:44 AM

Done? the main page suggests that the Incubator contents are yet to be imported.

Restricted Application removed a subscriber: Mjbmr. · View Herald TranscriptJun 19 2015, 5:44 AM
The_Discoverer reopened this task as Open.Jun 19 2015, 7:17 AM

I've changed the status to 'open' to highlight that the Latin script articles should be imported too. There's a discussion in this regard at [https://meta.wikimedia.org/wiki/Requests_for_new_languages/Wikipedia_Goan_Konkani#Discussion] .

Krenair closed this task as Resolved.Jun 19 2015, 2:19 PM

As far as I am concerned, this is done. Article imports are not a system administrator task. There's some global group on-wiki which deals with that.

gpaumier moved this task from Backlog to Triaged on the Notice board.Jun 20 2015, 1:43 AM
gpaumier moved this task from Triaged to Archive on the Notice board.Jun 26 2015, 8:27 PM