Page MenuHomePhabricator

More <span> corruption (unknown source)
Closed, InvalidPublic

Event Timeline

Jdforrester-WMF raised the priority of this task from to High.
Jdforrester-WMF updated the task description. (Show Details)
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 20 2015, 6:22 PM
NicoV added a comment.Apr 20 2015, 6:33 PM

For information, it seems to have appeared with the last deployment on frwiki : T71494 seemed fixed for like a week, and this seems to have happened only after.

Elitre added a subscriber: Elitre.Apr 20 2015, 7:54 PM
Jay8g added a subscriber: Jay8g.Apr 21 2015, 3:17 AM

There seem to be a few distinct issues.


https://fr.wikipedia.org/w/index.php?title=La_route_M%C3%A9diterran%C3%A9e&curid=9025986&diff=113836353&oldid=113835437
<span lang="EN-US">Church of Santa Maria Novella Florence</span>
Text marked as being in a different language than wiki language.
T96101: <span lang="XX-YY"> added on ZZ Wikipedia


https://fr.wikipedia.org/w/index.php?title=Lyc%C3%A9e_Paul_Eluard&diff=prev&oldid=113829511
https://fr.wikipedia.org/w/index.php?title=Lyc%C3%A9e_Paul_Eluard&diff=prev&oldid=113829346
https://fr.wikipedia.org/w/index.php?title=Lyc%C3%A9e_Paul_Eluard&diff=prev&oldid=113828982
<span> </span>:
Space before colon, inside <ref/>, is wrapped in a <span/>. Perhaps related to T94509: Space before colon in French is wrapped in mw:Placeholder wrapper?


https://fr.wikipedia.org/w/index.php?title=Chip-Seq&oldid=113950851
<span lang="FR">Séquençage simple-molécule</span>
https://fr.wikipedia.org/w/index.php?title=Liberlande&diff=prev&oldid=113947611
<span lang="fr">Citoyenneté</span>
Text marked as being in a different language, except in this case the language is identical to wiki language. Whatever the reason for this is, such annotations should be stripped anyway.
T95708: <span lang="XX-YY"> added on XX Wikipedia


https://fr.wikipedia.org/w/index.php?title=Centre_collaborateur_OMS_pour_la_recherche_et_la_formation_en_sant%C3%A9_mentale_%28CCOMS_Lille%29&oldid=114181936
(This page has been deleted, so I don't know what was in this diff.)

As I recall, the last one was a newly created article with VE with each line begin inside <span lang="FR">...</span>, so several dozens of those

matmarex closed this task as Invalid.Apr 21 2015, 12:23 PM
matmarex claimed this task.

I managed to reproduce the one with <span> </span> consistently, filed as T96673.

Since we have a separate bug for every issue reported here now, let's close this? Thanks for the bug reports! :)