Page MenuHomePhabricator

"Rendered topic not found when attempting to scroll!..." when trying to load a topic from the list in "Browse topics"
Closed, ResolvedPublic

Description

Browser - Chrome.

Click on 'Browse topics' - and click on 'Pineapple surprise'. The topic won't be displayed.

There is no indication to a user why the topic is not displayed/found. In Console the following errors are displayed:
[FLOW] Rendered topic not found when attempting to scroll!
mw.flow.debug.FlowComponent.debug
_scrollWithoutInfinite
(anonymous function)
jQuery.Callbacks.fire
jQuery.Callbacks.self.fireWith
jQuery.extend.Deferred.jQuery.each.deferred.
(anonymous function)
(anonymous function)
jQuery.Callbacks.fireself.fireWith
jQuery.Callbacks.self.fireWith
done
jQuery.ajaxTransport.send.callback

Event Timeline

Etonkovidova raised the priority of this task from to Needs Triage.
Etonkovidova updated the task description. (Show Details)
Etonkovidova added a subscriber: Etonkovidova.
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Mattflaschen-WMF triaged this task as High priority.Apr 23 2015, 5:50 PM

Change 207797 had a related patch set uploaded (by Mattflaschen):
Fix history permission check in RevisionFormatter

https://gerrit.wikimedia.org/r/207797

Change 207797 merged by jenkins-bot:
Fix history permission check in RevisionFormatter

https://gerrit.wikimedia.org/r/207797

DannyH closed this task as Resolved.May 4 2015, 10:38 PM
DannyH added a subscriber: DannyH.

Still reproducible on http://en.wikipedia.beta.wmflabs.org/w/index.php?title=Talk:Flow_QA

Notes for testing:

  • Delete a topic
  • Browse topics still displays the deleted topic - click on it.
  • "[FLOW] " "Rendered topic not found when attempting to scroll!" is displayed.

Not exactly the same bug but very valid. Good catch!

This is how I would word it: Hiding, Deleting, or Suppressing a topic does not remove it from the ToC. Clicking on it in the ToC does not do anything and the error "Rendered topic not found when attempting to scroll!" is display in the console.

I have filed it here: T98597: Hiding, Deleting, or Suppressing a topic does not remove it from the ToC until page reload