Wikimedia Hackathon 2015 program
Closed, ResolvedPublic

Description

We need a Wikimedia hackathon 2015 program to schedule timed activities and to inform about the rest of hacking activities unscheduled but expected.

Elements of a well promoted activity

  • A task created in Phabricator and assigned to the person in charge.
  • A clear title preceded with "Training:", "Meeting:", "Hacking:" or any other word that describes the type of activity.
  • A description up to date, including links for background information and etherpad (if you use one).
  • If your session is pre-scheduled, add the time and room.
  • If you are seeking volunteers, IRC nicks and links to profile pictures will help you being found.

Tasks associated with Wikimedia-Hackathon-2015 that look incomplete or haven't seen any activity from their promoters in the past weeks might be removed from this project in order to keep the list of activities clean.

Qgil created this task.Apr 24 2015, 10:31 AM
Qgil updated the task description. (Show Details)
Qgil raised the priority of this task from to Normal.
Qgil claimed this task.
Qgil added subscribers: Ckoerner, Sumit, Eloquence and 7 others.

Hello,

I don't know if I'm relevant to give my opinion here but still, I will.

This is how we've thought the event:

Thursday 21 AM: The planning team arrives and start preparing
Thursday 21 PM: First attendees who want to help arrive and we welcome them. We then continue to prepare and try everything to be sure not to have any issue during the week-end.

Friday 22: Arrival of attendees, for the whole day. In a first time, a WMFr employee will welcome them. They'll afterward registrate at the welcome desk at Valpré, get the keys to their room and a volunteer will bring them to their room.
Friday 22 evening: Aperetive with a Quiz (We usually call that a PubQuiz here in Paris, but regarding the absence of Pub, we'll have to fine another amazing name). The spirit is to form teams of 6, composed of 2 newbies, 2 WMF staff and 2 coders. Questions will be related to WM history & projects, to the city of Lyon and to technical IT questions. Plus Wine. Yeah.

Saturday 23:
9 to 10: Breakfast available
10 to 12: Opening Ceremony
12 to 14: Lunch available
14 to 15: Conference for Newbies (by WMF)
15 to 19: Coding
19+: Diner & Retrogaming night

Sunday 24:
10 to 11: Breakfast and "Librairies without borders" conference (http://www.librarieswithoutborders.org/)
11 to 12: Coding
12 to 14: Lunch available
14 to 16: Coding
16 to 17: WMF conference
17 to 19: Coding
19+: Gala Diner (Paëlla)

Monday 25:
10 to 11: Breakfast and "Simplon" conference (http://simplon.co/)
11 to 12: Coding
12 to 14: Lunch available
14 to 16: Coding
16+: Demo & Closing Ceremony

Tuesday 26:
Order an Uber
Give keys back
Get home, proud.

This looks great Alex - the only real comment I have is that 10am - 12am is a long time to spend on the opening ceremony if we are not able to help people get working before lunch and in that case we would have only 2.5 days to hack.
Things to accomplish in the opening:

  • and guest speakers talk
  • WMFr introduce the event and logistics
  • Quim and Rachel explain scheduling and sessions
  • We open the floor to participants who want to speak and advertise their project, identify themselves to newbies, ask for help, or say anything in general to the group.

I think if we want everyone to attend the opening we should keep it to an hour or an hour and a half and make sure it is all interesting and productive and moves along quickly. Otherwise many of the people will start to get restless and may even walk out of the opening to go start hacking on their own.

Is it possible to start at 9am on Saturday? Then people can have an hour before lunch to get organized. We have have the hour long session for Newbies and then people can get down to work after lunch? We can have the official start be 10am on the other two days and people can just show up early and hack if they like.

Just as a quick note, to help with language miscommunication lets use the words "session, track, talk, sprint, lecture, discussion" etc instead of "conference. Generally "conference" refers to an entire event and not just a session or keynote. Maybe I am the only one confused, but I guess a few others might be as well. :)

I think you can put this schedule up on the hackathon page and just note at the top that it is a draft and might change.
Maybe also just add "24 hour hacking space available" or something at the end of the schedule on Saturday and Sunday too.

@AlexCella, I put together a draft from your notes. I incorporated the suggestions from @Rfarrand.

https://www.mediawiki.org/wiki/Wikimedia_Hackathon_2015/Program

Edit to your heart's content.

P.S. Can you tell I'm excited for Lyon?

Qgil raised the priority of this task from Normal to High.May 6 2015, 5:36 AM
Qgil added a comment.May 7 2015, 11:47 AM

Alright, sorry for my silence in this task but I couldn't open more threads in my brain during these busy days.

@AlexCella, thank you very much for the first step laying out a schedule, and @Ckoerner (hi!) thank you very much for moving it on-wiki. Let's have https://www.mediawiki.org/wiki/Wikimedia_Hackathon_2015/Program and one and only program, showing the best of our assumptions at any time.

Steps:

  1. Clarify what are the earliest and latest times that a session can be scheduled. Now the program gives the impressions that i.e. on Saturday there is more time for eating and partying than coding (i.e. 1h in the morning only).
  2. Confirm the times of activities that will block the scheduling of other activities i.e. the opening session.
  3. Identify the rooms available for the event, how many and which capacity for each room in classroom (for training/meeting) or workshop (hacking) setups.

Once we have this, we will be able to have a grid, and we will be able to start scheduling sessions.

Since this is a hackathon, the majority of activities don't require any scheduling in advance. However, based on previous experiences @Rfarrand and me think that it is a good idea to schedule the sessions welcoming newcomers, so they can plan better their priorities before and during the event, learn about the topics of the sessions that sound interesting, etc.

I'm going through the training and meeting proposals at the Wikimedia-Hackathon-2015 workboard, asking whether those sessions are confirmed and what are their needs. With this information I will start populating the grid.

Qgil moved this task from Backlog to Ready to Go on the ECT-May-2015 board.May 12 2015, 4:02 PM

@Qgil: I still have some stuff to add (dinner, parties, etc), but feel free to start editing away on the schedule here https://www.mediawiki.org/wiki/Wikimedia_Hackathon_2015#Schedule
Please don't put anything in the "Public conferences" space for now.

Qgil updated the task description. (Show Details)May 18 2015, 11:04 AM
Qgil set Security to None.
Clemclemmm added a subscriber: Clemclemmm.EditedMay 18 2015, 12:09 PM

sorry for this dummies question,
but what is the difference between
"Training:", "Meeting:", "Hacking:"

(in other words, it's for determine where i put my task in ...)

is "hacking" a session for coding, or just for thinking about a subject.
"meeting" just a way to expose a problem, and the way to anounce a "hacking" session
"training" is the previous step ?
"meeting" then "training" then "hacking" then "meeting" (for restitution)
is the good procedural way ?

Qgil added a comment.May 18 2015, 12:18 PM

In a meeting the goal is to discuss something among peers.

In a training session the goal is to share knowledge one-to-many.

A hacking project is about coding or other types of actual work.

I hope this helps finding the best category for your session.

Anomie added a subscriber: Anomie.May 18 2015, 6:36 PM

@Qgil: The message you posted implies that we should add "confirmed meetings" to the wiki schedule page. But no one has said anything about a room or timeslot for T99002.

Qgil added a comment.May 19 2015, 6:40 AM

@Anomie, this is the case for many sessions proposed. I recommend you to schedule your session in a small room, be there, run the session if others show up, keep doing your work if not.

@Anomie, this is the case for many sessions proposed. I recommend you to schedule your session in a small room,

So just pick one at random?

be there, run the session if others show up, keep doing your work if not.

That was my plan.

@Anomie , the schedule lists the number of people that can fit in each room. Otherwise they are generally pretty similar with the exception of the auditorium and the public space. Those two would not be good options, any of the others would. Hope that helps.

Elitre added a subscriber: Elitre.May 22 2015, 5:24 PM

I'd be interested in getting a room for 1h or so for T91108. Last year this activity was completely online, but I think that it would be great to actually gather people in a physical space. I'm also OK with attaching this to any other "session" or activity closely related to translations.

Qgil added a comment.May 23 2015, 2:50 PM

Just checking: do you mean in Lyon? If so, who could drive this? I'm happy to chase whoever you name. :)

Oops, no, sorry, wrong task. :) Thanks for pointing this to me!

Qgil closed this task as Resolved.May 24 2015, 9:25 PM

The program is working on its own. Mission completion.