Page MenuHomePhabricator

Wikitext info links at the Flow reply area (in wikitext mode) should open in a new window
Closed, ResolvedPublic

Description

When writing in a text area using the wikitext editor on Flow, a link to lean wikitext is provided inside the text area.
Currently, the link tries to open in the current window which is not very useful: the user gets a message warning that she is going to leave the page and has two options (a) leave the page losing the current text, or (b) remain in the page without learning how to use wikitext.

Since the link is providing in the editing environment, opening it in a new tab by default would be the expected behaviour to avoid data los and unnecessary prompting the user.

Event Timeline

Pginer-WMF raised the priority of this task from to Needs Triage.
Pginer-WMF updated the task description. (Show Details)
Pginer-WMF added a subscriber: Pginer-WMF.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 28 2015, 5:06 PM
Mattflaschen-WMF triaged this task as High priority.Apr 28 2015, 5:45 PM

Change 208845 had a related patch set uploaded (by Catrope):
Make "uses wikitext" link open in new tab

https://gerrit.wikimedia.org/r/208845

Change 208845 merged by jenkins-bot:
Make "uses wikitext" link open in new tab

https://gerrit.wikimedia.org/r/208845

DannyH closed this task as Resolved.May 6 2015, 8:33 PM
DannyH added a subscriber: DannyH.

works on Beta