Page MenuHomePhabricator

Median time to review for Gerrit Changesets, per month
Closed, InvalidPublic

Description

Maybe I'm just too stupid to find this in korma, I think I once saw this? If it exists, feel free to close this task and point me to the existing page:

For T94578: Most basic Tech Community metrics are published and up to date we'd like to have a graph showing the median time to review for Gerrit changesets, per month.
This will allow us to see whether our time-to-review gets worse and if more (social) efforts should be put into encouraging people to review and to find code areas that noone feels responsible for.

Event Timeline

Aklapper created this task.Apr 30 2015, 9:40 PM
Aklapper raised the priority of this task from to High.
Aklapper updated the task description. (Show Details)
Aklapper added a project: wikimedia.biterg.io.
Aklapper added subscribers: Aklapper, Qgil.
Aklapper added a subscriber: Dicortazar.

@Dicortazar: I'm tentatively assigning this to you as this is something we really do want to get into place in the next five weeks.
Feel free to move/drag this task to the "Doing" column on the project's workboard when working on this (or provide any updates here).
Thank you!

@Aklapper, ok, let's discuss about this, this Friday. I guess we have these data for Bugzilla (work in progress for Maniphest), but not for Gerrit, at least in the dashboard.

Maybe I'm just too stupid to find this in korma, I think I once saw this?

This must have already existed at some time, seeing the screenshot in T68265: Code review time must be on merged patches, not closed (e.g. abandoned or merged) ones (but no URL given there)? Anybody knows what happened?

@Aklapper, as far as I know, those charts were wrong at some point are were moved to the third and fourth chart in korma.wmflabs.org/browser/gerrit_review_queue.html

However, those do not show the time to merge, but the life of the still opened changesets.

The third chart shows information about the mean and median life of the changesets that are open in each of the months. For instance, if you close a pretty old issue, that total amount will decrease in the following month. If that chart keeps increasing, that would mean that the changesets are simply there.

The fourth chart is similar, but divided by affiliation.

There's some extra info at https://www.mediawiki.org/wiki/Community_metrics#Gerrit_review_queue .

Qgil added a comment.May 29 2015, 7:09 AM

The two graphs shown in F13952 at T68265 correspond to what is today "Age of open changesets (monthly snapshots)" and "Age of open changesets by affilation (monthly snapshot)".

Until now, we have been calculating the median age of the open changesets. If this is what you want, we have the metrics and this task should be closed as invalid. If what you want is the age of the changesets, then we should mark this task as a duplicate of T68265 and continue the discussion there.

Aklapper closed this task as Invalid.Jun 1 2015, 11:26 AM

Until now, we have been calculating the median age of the open changesets. If this is what you want, we have the metrics and this task should be closed as invalid.

I think that's pretty much what we want, so I'm closing this task (and updated T94578).

If what you want is the age of the changesets, then we should mark this task as a duplicate of T68265 and continue the discussion there.