Page MenuHomePhabricator

When using UploadWizard, thumbnails fail to appear or files are missing on the "Release rights" webpage
Closed, ResolvedPublic

Description

When using Mozilla Firefox 37.0.2, I frequently encounter these related problems when using the UploadWizard.

  1. When clicking on the "Upload" button, the file selection window that opens sometimes does not show thumbnails properly. Closing the window, refreshing the web page, and clicking "Upload" again sometimes solves the problem.
  1. After the files have been selected, the website is unable to retrieve thumbnails of the images. Either a black rectangle appears, or a "broken image" icon.
  1. After the files appear to have been loaded and I click "Next", on the "Release rights" webpage when I need to declare whether the files were all created by me, sometimes some of the files selected on the previous page are missing. Occasionally, all the files are missing and the page presents with no buttons at all.

Occasionally, trying to use the UploadWizard causes Firefox to crash.

Event Timeline

Smuconlaw created this task.May 1 2015, 2:13 PM
Smuconlaw raised the priority of this task from to Needs Triage.
Smuconlaw updated the task description. (Show Details)
Smuconlaw added a project: CommonsMetadata.
Smuconlaw added a subscriber: Smuconlaw.
Restricted Application added a project: Multimedia. · View Herald TranscriptMay 1 2015, 2:13 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Smuconlaw renamed this task from When using UploadWizard, to When using UploadWizard, thumbnails fail to appear or files are missing on the "Release rights" webpage.May 1 2015, 2:14 PM
Smuconlaw set Security to None.
Smuconlaw updated the task description. (Show Details)May 1 2015, 2:18 PM

I just retried the uploading process, and one of the files failed to upload with the error message "Unknown error: 'internal_api_error_DBConnectionError'".

This is what the Web console recorded on one failed attempt:

Image corrupt or truncated: data:image/jpeg;base64,/9j/4AAQSkZJRgABAQAAAQABAAD/4S/+RXhpZgAATU0AKgAAAAgACwEPAAIAAAAGAAAAkgEQAAIAAAAJAAAAmAESAAMAAAABAAEAAAEaAAUAAAABAAAAogEbAAUAAAABAAAAqgEoAAMAAAABAAIAAAExAAIAAAAEOC4zAAEyAAIAAAAUAAAAsgITAAMAAAABAAEAAIdpAAQAAAABAAAAxoglAAQAAAABAAAD5AAABQZBcHBsZQBpUGhvbmUgNQAAAAAASAAAAAEAAABIAAAAATIwMTU6MDQ6MjMgMTA6NDk6NDkAACCCmgAFAAAAAQAAAkyCnQAFAAAAAQAAAlSIIgADAAAAAQACAACIJwADAAAAAQyAAACQAAAHAAAABDAyMjGQAwACAAAAFAAAAlyQBAACAAAAFAAAAnCRAQAHAAAABAECAwCSAQAKAAAAAQAAAoSSAgAFAAAAAQAAAoySAwAKAAAAAQAAApSSBAAKAAAAAQAAApySBwADAAAAAQADAACSCQADAAAAAQAQAACSCgAFAAAAAQAAAqSSFAADAAAABAAAAqySfAAHAAAA6AAAArSSkQACAAAABDYxNgCSkgACAAAABDYxNgCgAAAHAAAABDAxMDCgAQADAAAAAQABAACgAgAEAAAAAQAACZCgAwAEAAAAAQAADMCiFwADAAAAAQACAACjAQAHAAAAAQEAAACkAgADAAAAAQAAAACkAwADAAAAAQAAAACkBQADAAAAAQAhAACkBgADAAAAAQAAAACkMgAFAAAABAAAA5ykMwACAAAABgAAA7ykNAACAAAAIgAAA8IAAAAAAAAAAQAAAA8AAAAMAAAABTIwMTU6MDQ6MjMgMTA6NDk6NDkAMjAxNTowNDoyMyAxMDo0OTo0OQAAABjBAAAGVgAAEu0AAAd+///u2wAAA/UAAAAAAAAAAQAAAGcAA 9k=
NS_ERROR_NOT_AVAILABLE: load.php:543:0
NS_ERROR_NOT_AVAILABLE: load.php:543:0

Tgr added a subscriber: Tgr.May 4 2015, 11:45 AM

I just retried the uploading process, and one of the files failed to upload with the error message "Unknown error: 'internal_api_error_DBConnectionError'".

That sounds like a transient error on the server side, such as a DB connection timeout. If it occurs again, it could be something serious though. In that case, could you open a new bug report for it?

Not sure what to do about this one - sounds like all the other things you have experienced is just the result of a spotty internet connection. Do other pages work normally?

Tgr edited projects, added UploadWizard; removed CommonsMetadata.May 4 2015, 11:45 AM
MarkTraceur moved this task from Untriaged to Next up on the Multimedia board.Aug 27 2015, 3:50 PM
Restricted Application added subscribers: Steinsplitter, Matanya. · View Herald TranscriptAug 27 2015, 3:50 PM
Jdforrester-WMF triaged this task as Medium priority.Sep 4 2015, 6:47 PM

I just tested this with firefox 41.0 and I can't seem to be able to reproduce this

I am still experiencing this transiently. The error message is: "The upload succeeded, but the server could not get a preview thumbnail." I was using Firefox 40.0.3.

@Jacklee: how do experiencing this issue? Is there a specific image that consistently fails? Or some specific scenario in which this error always occurs? Do you still experience this issue now, 9 months later? :)

This indeed looks like a transient error and we probably can't really do anything about it. Unless if it happens consistently or often...

I think it was a transient problem. I have not experienced it for some time.

matthiasmullie closed this task as Resolved.Jul 19 2016, 10:50 AM
matthiasmullie claimed this task.