Page MenuHomePhabricator

Error when visiting Nearby on Wikpedia (all of them)
Closed, ResolvedPublic

Description

Visiting http://en.m.wikipedia.beta.wmflabs.org/wiki/Special:Nearby I see an error and the page does not work at all. Happens in enwiki too.

Chrome
Version 42.0.2311.135 (64-bit)

On Firefox 39 works fine.

On Firefox for Android it doesn't work at all.
On Chrome for Android either.

Error: Module not found: settings Error: Module not found: settings {stack: (...), message: "Module not found: settings"}log @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=minerva&version=20150506T…:176handler @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=minerva&version=20150506T…:153jQuery.Callbacks.fire @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=minerva&version=20150506T…:45jQuery.Callbacks.self.fireWith @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=minerva&version=20150506T…:46jQuery.Callbacks.self.fire @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=minerva&version=20150506T…:46mw.track @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=minerva&version=20150506T…:153runScript @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=minerva&version=20150506T…:161execute @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=minerva&version=20150506T…:162mw.loader.implement @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=minerva&version=20150506T…:168(anonymous function) @ VM110:91(anonymous function) @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=minerva&version=20150506T…:4jQuery.extend.globalEval @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=minerva&version=20150506T…:4mw.loader.work @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=minerva&version=20150506T…:164request @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=minerva&version=2015

Event Timeline

Jhernandez raised the priority of this task from to High.
Jhernandez updated the task description. (Show Details)
Jhernandez moved this task to To Triage on the Readers-Web-Backlog board.
Jhernandez added a subscriber: Jhernandez.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2015, 10:59 AM

I'm getting three scenarios when trying to replicate this problem on desktop. These problems appear to be independent of clearing the cache.

  1. Spinner appears and spins forever.
  2. No pages found nearby. (no idea if this is correct, using desktop may be wonky even with sharing location)
  3. The JS "Module not found" error Jhernandez mentioned in the desription.

The overwhelming majority of the time I was receiving the 3rd scenario.

Cannot reproduce locally on master.

It looks like this is probably because 'mobile.startup' includes mobile.startup/Schema.js which requires settings, but 'mobile.startup' doesn't explicitly declare mobile.settings as a dependency.

Change 209833 had a related patch set uploaded (by Kaldari):
Adding mobile.settings as dependency for mobile.startup

https://gerrit.wikimedia.org/r/209833

Change 209833 merged by jenkins-bot:
Adding mobile.settings as dependency for mobile.startup

https://gerrit.wikimedia.org/r/209833

I assume, that this should be backported @kaldari ?

Change 210013 had a related patch set uploaded (by Phuedx):
Adding mobile.settings as dependency for mobile.startup

https://gerrit.wikimedia.org/r/210013

Change 210014 had a related patch set uploaded (by Phuedx):
Adding mobile.settings as dependency for mobile.startup

https://gerrit.wikimedia.org/r/210014

phuedx closed this task as Resolved.May 11 2015, 6:05 PM
phuedx claimed this task.
phuedx added a subscriber: phuedx.

Signing this off as it's technical. We should get this deployed either tonight or tomorrow afternoon.

Change 210013 abandoned by Kaldari:
Adding mobile.settings as dependency for mobile.startup

Reason:
No longer needed

https://gerrit.wikimedia.org/r/210013

Change 210014 abandoned by Phuedx:
Adding mobile.settings as dependency for mobile.startup

https://gerrit.wikimedia.org/r/210014