Page MenuHomePhabricator

Main menu doesn't render on the Main Page
Closed, ResolvedPublic

Description

Visit http://en.m.wikipedia.beta.wmflabs.org/wiki/Main_Page whilst anon in stable without any query parameters. The menu is invisible.

One of the browser tests relating to the main menu is failing as a result:
e.g. https://integration.wikimedia.org/ci/job/browsertests-MobileFrontend-SmokeTests-linux-chrome-sauce/117/testReport/junit/(root)/Menus%20open%20correct%20page%20for%20anonymous%20users/Check_links_in_menu/

It seems under some circumstances the menu is not rendering at all.
I'm seeing this on mediawiki.org @phuedx so we should fix this before next deploy...

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : wmf/1.26wmf6Support for cached menu data in HTML
mediawiki/extensions/MobileFrontend : masterSupport for cached menu data in HTML

Event Timeline

Jdlrobson raised the priority of this task from to Needs Triage.
Jdlrobson updated the task description. (Show Details)
Jdlrobson added a project: Readers-Web-Backlog.
Jdlrobson moved this task to Incoming on the Readers-Web-Backlog board.
Jdlrobson added a subscriber: Jdlrobson.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 13 2015, 3:16 PM
Jdlrobson renamed this task from Problems rendering the main menu to Main menu doesn't render on the Main Page.May 14 2015, 8:45 AM
Jdlrobson triaged this task as High priority.
Jdlrobson updated the task description. (Show Details)
Jdlrobson set Security to None.
Jdlrobson added a subscriber: phuedx.

So.. the menu has the right number of list items in it but they have no contents.
mw.config.get( 'wgMFMenuData' ) is present but it's using the old cached version

On a broken page in wgMFMenuData an item looks like:

class: "mw-ui-icon mw-ui-icon-before mw-ui-icon-home "
data-event-name: "home"
href: "/wiki/Main_Page"
name: "home"
text: "Home"

On a working page

components: Array[1]
name: "home"

So basically the problem is on cached pages and the fix is map the old format to the new format.

Ugh. We need a strategy to deal with this sort of caching. Maybe even something in our toolchain (pre-commit hook?) that flags that a change might break because of this sort of caching.

Change 211078 had a related patch set uploaded (by Phuedx):
Follow on Ibf1cea

https://gerrit.wikimedia.org/r/211078

phuedx claimed this task.May 15 2015, 2:38 PM

Change 211078 merged by jenkins-bot:
Support for cached menu data in HTML

https://gerrit.wikimedia.org/r/211078

Change 212050 had a related patch set uploaded (by Kaldari):
Support for cached menu data in HTML

https://gerrit.wikimedia.org/r/212050

Change 212050 merged by jenkins-bot:
Support for cached menu data in HTML

https://gerrit.wikimedia.org/r/212050

phuedx closed this task as Resolved.May 20 2015, 1:30 PM
phuedx removed a project: Patch-For-Review.