Page MenuHomePhabricator

[EPIC] Improve the status quo of mobile web performance
Closed, ResolvedPublic

Description

Copied from https://phabricator.wikimedia.org/T97570#1265298
"The size of the HTML served at pageload seems to be where the biggest performance gains are to be had on mobile web at the moment. One area to explore is the automated size reduction of the HTML via Parsoid. Another is to only serve the lead section on pageload and load the rest of the page asynchronously. A secondary improvement-worthy area is the current firstPaint performance hampered by the amount of CSS and JS served in the head. Some of which has already been identified as low-hanging fruit. Lastly, the idea of loading images on demand when they are scrolled to could be experimented with."

Related Objects

StatusAssignedTask
DuplicateJhernandez
ResolvedJdlrobson
ResolvedGilles
ResolvedJdlrobson
Resolvedbmansurov
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedJdlrobson
Invalidmatmarex
ResolvedJdlrobson
DeclinedJdlrobson
OpenNone
ResolvedFlorian
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedJdlrobson
DeclinedJdlrobson
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedGilles
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedFlorian
InvalidFlorian
ResolvedJdlrobson
ResolvedFlorian
ResolvedJdlrobson
ResolvedAlbert221
ResolvedJdlrobson
DuplicateNone
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedJdlrobson
DeclinedJdlrobson
ResolvedJdlrobson

Event Timeline

Jdlrobson raised the priority of this task from to Needs Triage.
Jdlrobson updated the task description. (Show Details)
Jdlrobson added a subscriber: Jdlrobson.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 13 2015, 5:48 PM
Glaisher updated the task description. (Show Details)May 15 2015, 11:06 AM
Glaisher set Security to None.

copied description from T98987 as this one was blank

phuedx renamed this task from Make mobile web more performant. to [EPIC] Make mobile web more performant..May 15 2015, 2:33 PM
phuedx added a project: Epic.

Notes from meetup @ Hackathon

  1. Establish a timing baseline for median of pages served
  2. Is time to first paint the right metric?
  3. Can we eliminate the top modules in mobile?
  4. Revisit banners mobile (loads desktop data stuff as well) -- need someone from FR to collaborate
  5. How can we load lead image faster?
  6. Image optimization might really help as well
  7. Tooling: how do we detect regressions via automated tools? (Web + Perf team)
    1. Can this be part of automated builds?
    2. Perf has a chromium client that periodically d/ls pages.
  8. Need a strategy to work better with community about common.js (replace with gadget)
  9. Inline CSS may be a problem with versioning (ESI may help)
  10. BBC is good example to follow in general
  11. HTTP2 is also encouraging (future)

Graphs are at gdash.wikimedia.org/dashboards/frontend

He7d3r added a subscriber: He7d3r.May 23 2015, 8:56 PM

The Mobile Apps Team has been working on a content service that strips redundant HTML on the server side to reduce page weight and data usage, and performs transforms on the server rather than the client to reduce time spent reshuffling content. Could mobile web also use this service? @bearND will know more.

Gilles added a subscriber: Gilles.May 29 2015, 11:13 AM
Deskana removed a subscriber: Deskana.Jun 22 2015, 3:47 PM

Hey, I've added this epic as a blocker to our quarterly goal about performance on mobile web T104432.

I want to keep it as a reference since there are a lot of great improvements we could implement but I'd want Readers-Web-Backlog to first measure & report, make hypothesis and scope pieces of work and tackle them once at a time measuring after implementation the actual improvements (if any).

This epic has a bunch of subtasks that we could fit into batches of work to do through the quarter after we've set baselines.

Jhernandez triaged this task as High priority.Jul 2 2015, 9:30 AM

I want to contribute to wikimedia and for that Outreachy intership program looks perfect fit for me.
I am really interested in mobile web and have already fixed some bugs of MobileFrontend extension (#1 ,#2). I am looking for project idea related to this task, I will be thankful if someone can suggest any idea to me to contribute for wikimedia.

Jdlrobson renamed this task from [EPIC] Make mobile web more performant. to [EPIC] Make existing mobile web experience more performant..Sep 18 2015, 5:37 PM
Jdlrobson renamed this task from [EPIC] Make existing mobile web experience more performant. to [EPIC] Improve the status quo of mobile web performance.Sep 18 2015, 5:47 PM
Jdlrobson closed this task as Resolved.Jan 11 2016, 9:42 PM
Jdlrobson claimed this task.

Having this bug around is confusing since most of the work is focused in T113066 now.
Have moved the blocking tasks over there to keep things less confusing.