Page MenuHomePhabricator

[Migrated] No vertical scroll bar in diff window
Closed, ResolvedPublic

Description

Mandarax 10:14, 6 November 2010 (UTC) wrote:

No vertical scroll bar appears in the diff window. (The horizontal one does correctly show when appropriate.)


Site: en.wiki
OS: Windows 7 SP 1
.NET: 2.0.50727.3615
Version: Various versions through most recent SVN 8097
Workaround: Restart AWB, or use scroll wheel or arrow keys when the focus is on the diff window. Note that clicking in the diff window puts the focus on the ''edit box''. To focus on the diff window, click on Diff button or press Ctrl-d or Alt-d.

Event Timeline

Josve05a raised the priority of this task from to Needs Triage.
Josve05a updated the task description. (Show Details)
Josve05a added a project: AutoWikiBrowser.
Josve05a added a subscriber: Josve05a.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 15 2015, 11:08 PM

Mandarax 10:50, 6 November 2010 (UTC) wrote:

Note: I've switched to SVN 7333 because 7351 is too inconvenient and dangerous, making it too difficult to determine what changes will be made. 7333 always displays the vertical scroll bar whether needed or not.

@GoingBatty 15:46, 6 November 2010 (UTC) wrote:

I see the horizontal scrollbar in the diff window in SVN 7351. I'm using XP with .Net version 2.0.50727.1873.

@Rjwilmsi 16:27, 6 November 2010 (UTC) wrote:

I have noticed this intermittently on various versions (over last year or so). Restarting AWB seemed to work.

Mandarax 19:47, 28 April 2011 (UTC) wrote:

I hadn't seen this in the almost six months since my report, but then it happened today, with SVN 7634. Restarting AWB does fix it, but I figured I'd mention that it's still happening ''very'' intermittently.

Mandarax 18:02, 27 May 2011 (UTC) wrote:

I don't know if this will provide any additional information to help diagnose the problem, but today I opened two instances of SVN 7731 at the same time and both had the problem. I was curious what would happen when opening a third; it also had the problem.

Mandarax 06:43, 4 July 2012 (UTC) wrote:

This continues to occur, and has been happening to me more often lately – about three or four times in the last week. I'm now using SVN 8062. I understand that discovering the cause of an elusive bug such as this can be very difficult. But it's inconvenient to have to close and restart AWB when it happens. Until it gets fixed, would it be possible to add an option (maybe in the View menu or a right-click menu) to add the scrollbar? Or can the program automatically check to see if the scrollbar is enabled?

John of Reading (talk) 07:10, 4 July 2012 (UTC) wrote:

I've seen this from time to time, but only when I've started another program while AWB is loading. If AWB isn't in the foreground when it starts up, the vertical scrollbar is missing. The workaround is to quit, restart, and let it finish its initialisation in the foreground. I've not seen the scrollbar disappear partway through a session. Is this the behaviour that other users are seeing?

Mandarax 21:50, 4 July 2012 (UTC) wrote:

I've tried to make it happen by starting another program while AWB is loading or having another already-loaded program in the foreground when AWB starts, but in each case I got the scrollbar. I did see the scrollbar disappear during a session once. I finished one setting file with no scrollbar problems, then I started another setting file and the scrollbar was gone. It's ''possible'' that none of the pages in the first set required scrolling so I didn't notice a missing scrollbar, but I think that's unlikely.

SunCreator 22:24, 4 July 2012 (UTC) wrote:

I had the scroll bar disappear once in mid session. At the time I was running three copies of AWB. Perhaps the issue is low memory related. A restart of AWB fixed the problem.

@GoingBatty 01:22, 13 April 2013 (UTC) wrote:

Can you reproduce the bug in version 5.5.0.1?

Mandarax 03:52, 13 April 2013 (UTC) wrote:

I could never intentionally reproduce it; it happened intermittently. I just switched to 5.5.0.1, and I'll post if I see it again. (It did happen in 5.5.0.0, SVN 8979.)

Mandarax 22:30, 28 April 2013 (UTC) wrote:

It just happened in 5.5.0.1, SVN 9049.

Mandarax 18:20, 8 July 2013 (UTC) wrote:

And in 5.5.1.2, SVN 9316.

John of Reading (talk) 15:20, 1 September 2013 (UTC) wrote:

Mr Stephen has found a way to lose the scrollbar consistently. I've just reproduced this with AWB 5.5.1.2 SVN 9316 and Windows 7 SP 1: run AWB, minimise it and then exit, eg by logging off Windows. When it next starts the scrollbar is missing.

Josve05a triaged this task as Normal priority.Aug 22 2015, 11:27 PM
Rjwilmsi changed the task status from Open to Stalled.Feb 23 2016, 10:45 AM
Rjwilmsi added a subscriber: John_of_Reading.

@John_of_Reading

If it's possible to replicate the issue we need to see the user.config file
It will be in a subdirectory of
C:\Users\<user name>\AppData\Local\AutoWikiBrowser\

You may need to look at the timestamp of the files to get the correct one.

Yes, this is still happening. Minimize AWB; restart Windows; log in to Windows; start AWB - starts minimized; open the AWB window - no scrollbar in the upper pane. Now using AWB 5.8.5.1 and Windows 10.

<?xml version="1.0" encoding="utf-8"?>
<configuration>

<userSettings>
    <AutoWikiBrowser.Properties.Settings>
        <setting name="AskForTerminate" serializeAs="String">
            <value>False</value>
        </setting>
        <setting name="WindowLocation" serializeAs="String">
            <value>229, 25</value>
        </setting>
        <setting name="WindowSize" serializeAs="String">
            <value>1150, 855</value>
        </setting>
        <setting name="WindowState" serializeAs="String">
            <value>Minimized</value>
        </setting>
    </AutoWikiBrowser.Properties.Settings>
</userSettings>

</configuration>

@John_of_Reading OK, please try this:

Do as above. Close AWB. Edit the user.config file to change "Minimized" to "Maximized", save file. Reopen AWB, are scrollbars then OK?

Seems to me there must be some sort of bug in the .NET scrollbar logic, as scrollbars should be automatic by default. Perhaps as a workaround, if the above change works, we could never launch AWB minimized by ignoring that setting.

After that manual edit to user.config, AWB restarted maximized with all scrollbars showing. Your suggestion would be fine with me; when I start AWB I never want it to start minimized.

Rjwilmsi closed this task as Resolved.Feb 23 2016, 4:08 PM

rev 11942 Don't restore AWB Minimized as we lose diff scrollbars