Page MenuHomePhabricator

[Migrated] Duplicate tag fixes
Closed, ResolvedPublic

Description

@3gg5amp1e 19:53, 13 May 2015 (UTC) wrote:

It didn't detect and fix duplicate orphan tags inside the multiple issues template on https://en.wikipedia.org/w/index.php?title=Karin_Ireland&diff=prev&oldid=662198462


Site https://en.wikipedia.org/wiki/Karin_Ireland
OS Windows 6.1
.NET 2.0.50727.5485
Version 5.5.5.0
Workaround Manually deleted duplicate in edit box before clicking save

Event Timeline

Josve05a created this task.May 16 2015, 2:28 AM
Josve05a raised the priority of this task from to Needs Triage.
Josve05a updated the task description. (Show Details)
Josve05a added a project: AutoWikiBrowser.
Josve05a added subscribers: Josve05a, 3gg5amp1e.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 16 2015, 2:28 AM

@GoingBatty 02:57, 14 May 2015 (UTC) wrote:

@3gg5amp1e This may be a feature request instead - I don't see anything documented on WP:AWB/GF stating that AWB removes duplicate tags.

@3gg5amp1e 11:49, 14 May 2015 (UTC) wrote:

@GoingBatty: it seems really silly that it wouldn't since I've seen it reorder tags and put them inside of Multiple issues when there is already a multiple issues on the page (although I haven't seen it wrap multiple tags in multiple issues on its own or remove multiple issues template when there is only one issue, which it should probably do too.). Anyways, if you think it should be a request, please do move it for me as I'm not sure how to do that exactly or what the protocol is. Thank you very much @GoingBatty.

Magioladitis triaged this task as Low priority.May 17 2015, 11:07 PM
Magioladitis set Security to None.

The example article has two {{tl|orphan}} templates with different parameters. I don't think we should arbitrarily be removing one of the duplicates.

@3gg5amp1e: Do you have a suggestion for non-arbitary logic that could be used to remove one of the duplicates? GoingBatty (talk)

@GoingBatty date= should always be the older one and additional tags (like att= in this case) should always be the newest one. date is when it started being an issue, and the oldest is appropriate, other parameters (at least in the case of Orphan with att and few) and the most recent attempt is always the most appropriate.

https://en.wikipedia.org/wiki/User_talk:Addshore#.28Bot:_Adding_.7B.7BMultiple_issues.7D.7D_.7B.7BOrphan.7D.7D_.28Report_Errors.29.29 addbot may have been the cause of all of the duplicates being added in the first place, if it is of any importance.

Addshore added a comment.EditedJun 15 2015, 7:23 PM

I'll copy my reply on my talk page to here for convenience:

Thanks for bringing this to my attention! This isn't something I remember fixing or ever being mentioned before so I can only presume that it has not been spotted until now (had a quick search in my talk page archive and couldn't find anything.
As it was so long ago I can't remember exactly what script was used to make the changes. I don't remember ever adding general fixes such as white space fixes to my custom PHP scripts so the diffs almost make me feel like this was AWB O_o (I could be wrong however).
If we want a list of articles where this might have happened I could probably generate one with a DB query, If you feel I should fix the errors I would also be more than willing to do so!
Added myself to the phab task so I can follow it ·addshore· talk to me! 19:22, 15 June 2015 (UTC)

The query / list I mention should be visible at http://quarry.wmflabs.org/query/3989 once it runs!
Failed to run above as it takes so long, so here is a temp dump of the output http://tools.wmflabs.org/addshore-dev/addbotOrphanDupeFail.txt

The list above shows addbot's edit - some of which were correct, and some of which already fixed. I did a regex singleline search in the recent database dump for "{{Orphan.*{{Orphan" and found 100 articles, which I'm now fixing manually. Note that many of the issues were NOT caused by Addbot.

I support the logic that @3gg5amp1e provided above. Please note that there are other tags that are duplicated in the zeroth section of the article, such as {{unreferenced}}. An easier example is [[Nord Nord Ost]], where the two {{unreferenced}} tags have the same date. Interestingly, AWB doesn't add the {{multiple issues}} template in this case.

rev 11181, exactly identical maintenance tags will be deduplicated (so satisfies the [[Nord Nord Ost]] test case).

Confirmed - thanks!

Can we close this as resolved?

GoingBatty added a comment.EditedJun 18 2015, 4:01 AM

Please don't close it yet, as we haven't resolved the original issue.

Rjwilmsi closed this task as Resolved.Jun 18 2015, 9:35 AM
Rjwilmsi claimed this task.

rev 11199

Confirmed - thanks for making these updates!
I see you've added these updates to AWB's history page. Should they be added to the general fixes page too?
Thanks!

@GoingBatty Feel free to update the manual.

@Magioladitis - Sure, but which section of WP:AWB/GF? Tagger, or somewhere else?

GoingBatty reopened this task as Open.Jun 20 2015, 7:42 PM

SVN 11217 doesn't remove the duplicate {{one source}} tags on [[Dass Bank]].

Rjwilmsi changed the task status from Open to Stalled.Jun 20 2015, 7:50 PM

Our current list of maintenance templates is: "orphan", "BLP unsourced", "BLP sources", "cleanup", "underlinked", "dead end", "notability", "refimprove", "unreferenced"

@GoingBatty what do you want the full list to be?

@Rjwilmsi I am only requesting that {{one source}} be added to the list. Thanks!

The new functionality doesn't keep the {{Notability}} parameter from the oldest template - see [[Steve Malpass]] and [[See Monkey Songs]]

Rjwilmsi closed this task as Resolved.Jun 21 2015, 8:08 AM

rev 11222, add "one source" tag
rev 11223, handle one of dupe tags having unnamed first parameter

Confirmed - thanks for all your work on this!