Page MenuHomePhabricator

Place labels are clippy
Closed, ResolvedPublic

Description

Like, helluva clippy on mid zoom levels.

Event Timeline

MaxSem claimed this task.
MaxSem raised the priority of this task from to Needs Triage.
MaxSem updated the task description. (Show Details)
MaxSem added projects: Maps, Discovery.
MaxSem added a subscriber: MaxSem.
Yurik added a subscriber: Yurik.

https://github.com/nyurik/osm2pgsql-osm-bright.tm2source/commit/3ad020324d06e2d9c06b1f5f23cd9bd9d8615072

Comment:
Prevent label clipping by increasing all buffers
for the label layers to the maximum. This increases
the tile size somewhat, and we will need to optimize
the exact size at a later time.

Screen Shot 2015-05-19 at 10.46.40.png (448×785 px, 276 KB)
Still happening though waaaaaayy less frequently.

I suspect this is due to having too many labels in that region. Could you reduce their number for that zoom level? E.g. using sql LIMIT?

LIMIT wouldn't reduce density in a predictable way, I might need to play more with labelgrid parameters.

Setting to low priority because most of the labels show OK-ish now except for some areas.

rebuilding... z0-z10

There being too many labels and labels being cut off are separate issues. Yes, reducing the number of labels will decrease the number of cut off labels, but you can have high label density without cut off labels.

Well, the user-facing result is the same, that's why it makes sense to keep it in one place IMO. Anyway, https://github.com/nyurik/osm2pgsql-osm-bright.tm2source/pull/28 improves ordering and thus clipping looks much better. Also, it should be faster.

Lgtm, go ahead and merge ))

Data source commit: https://github.com/kartotherian/osm-bright.tm2source/commit/001d2674d0f9f6eb0dbb63347d3d9624d04b1710
Style commit: https://github.com/kartotherian/osm-bright.tm2/commit/44b464d277ee551dc3307e6ce623d40671eb5da9

Together, they improve at least Bay Area significantly for me. Still leaving the style open though because it's not fundamentally resolved.

MaxSem added a subscriber: Tfinc.

Even though I just pushed both latest commits directly to master, moving to Needs review for @Tfinc to look.

Looking better overall. I'm going to resolve and file new phab tasks if I find some more.

Firstly, congrats on the beta launch. Via twitter @mxfh directed my attention to: https://maps.wikimedia.org/#16/40.7121/-74.0072 Manhattan Tribeca and Southbridge Tower labels are also clipped.

Screenshot from 2015-09-17 22:20:35.png (443×443 px, 207 KB)

Yurik closed this task as a duplicate of T113391: City labels can get cut off.

Bleh, I hate this "merge" means the other will close.

i'm sure more labels are clippy, but there is no point to have a generic endless task. Reopen with specific cases (should be added to details, not comment)