Page MenuHomePhabricator

Login screen should have a display password checkbox
Closed, ResolvedPublic

Description

The create account screen has the option to display the password entered. This task is to duplicate that functionality for the login screen.

Event Timeline

Niedzielski raised the priority of this task from to Low.
Niedzielski updated the task description. (Show Details)
Niedzielski added a subscriber: Niedzielski.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 19 2015, 4:21 PM
Krenair added a subscriber: Krenair.

This is default off, right?

Correct. The create account checkbox defaults to unchecked.

csteipp added a subscriber: csteipp.

Please do default it to hide the password, with a "show password" checkbox (or checked "hide password"), unless we have very strong evidence that it's hurting the UX.

Change 229072 had a related patch set uploaded (by Deskana):
Show "Display password" check box on login screen

https://gerrit.wikimedia.org/r/229072

Change 229072 merged by jenkins-bot:
Show "Display password" check box on login screen

https://gerrit.wikimedia.org/r/229072

Any way we could use the material design toggle here?

Twitter has an interesting 'show password' with an eye
http://pttrns.com/applications/353?page=2

A checkbox feels like a bit strange on mobile

Signed off by design.

Checked on Checked with 2.0.108-alpha-2015-08-19 on Nexus5(Android 5.1)
Samsung Tablet Ce0168(Android 4.0.4)

The screenshots are from Nexus5(Android 5.1)

csteipp set Security to None.
Deskana closed this task as Resolved.Aug 27 2015, 3:41 AM
Deskana claimed this task.
sbassett moved this task from Backlog to Done on the Security-Team board.Jun 11 2019, 7:20 PM