Page MenuHomePhabricator

Mailman rejecting emails by members of private mailing list
Closed, ResolvedPublic

Description

Members of the wikimedia-search-private mailing list are getting their emails to the list stuck in the moderator queue from time to time with the message that they are not in the mailing list.

Event Timeline

Manybubbles assigned this task to RobH.
Manybubbles raised the priority of this task from to High.
Manybubbles updated the task description. (Show Details)
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 19 2015, 5:54 PM

Here is a mail I sent:

MIME-Version: 1.0
Received: by 10.202.173.205 with HTTP; Tue, 19 May 2015 10:45:47 -0700 (PDT)
In-Reply-To: <CAAUQgdB+WCTjP1Ns06zg-0EndAZ6TmYROq2eRcd_w5owSKiTnw@mail.gmail.com>
References: <mailman.0.1432056931.17492.wikimedia-search-private@lists.wikimedia.org>
	<CAAUQgdB+WCTjP1Ns06zg-0EndAZ6TmYROq2eRcd_w5owSKiTnw@mail.gmail.com>
Date: Tue, 19 May 2015 13:45:47 -0400
Delivered-To: neverett@wikimedia.org
Message-ID: <CAP+xBbUqEpxJ-mdMxyJT91317RctfRjwUSoKWLsvDDY8xHYSnA@mail.gmail.com>
Subject: Re: [Wikimedia-search-private] Fwd: Your message to
 Wikimedia-search-private awaits moderator approval
From: Nikolas Everett <neverett@wikimedia.org>
To: Internal communications for WMF search and discovery team <wikimedia-search-private@lists.wikimedia.org>, 
	Oliver Keyes <okeyes@wikimedia.org>
Content-Type: multipart/mixed; boundary=bcaec54fb4e2709bc6051672e1ea

--bcaec54fb4e2709bc6051672e1ea
Content-Type: multipart/alternative; boundary=bcaec54fb4e2709bc0051672e1e8

--bcaec54fb4e2709bc0051672e1e8
Content-Type: text/plain; charset=UTF-8

Yeah - I'm in there now trying. Uhhh - you are totally part of the mailing
list. I have no idea what is going on. Anyone with more mailman foo than I
have have any ideas/want to be an admin?

On Tue, May 19, 2015 at 1:40 PM, Oliver Keyes <okeyes@wikimedia.org> wrote:

> This is ridiculous. Can someone fix our permissions? :/
>
> ---------- Forwarded message ----------
> From:  <wikimedia-search-private-bounces@lists.wikimedia.org>
> Date: 19 May 2015 at 13:35
> Subject: Your message to Wikimedia-search-private awaits moderator approval
> To: okeyes@wikimedia.org
>
>
> Your mail to 'Wikimedia-search-private' with the subject
>
>     Re: [Wikimedia-search-private] Metrics/measurement and James
>
> Is being held until the list moderator can review it for approval.
>
> The reason it is being held:
>
>     Post by non-member to a members-only list
>
> Either the message will get posted to the list, or you will receive
> notification of the moderator's decision.  If you would like to cancel
> this posting, please visit the following URL:
>
>
> https://lists.wikimedia.org/mailman/confirm/wikimedia-search-private/721b351ba0c4585b7e161c43c381ac8f80fa92fa
>
>
>
> --
> Oliver Keyes
> Research Analyst
> Wikimedia Foundation
>
> _______________________________________________
> Wikimedia-search-private mailing list
> Wikimedia-search-private@lists.wikimedia.org
> https://lists.wikimedia.org/mailman/listinfo/wikimedia-search-private
>

--bcaec54fb4e2709bc0051672e1e8
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr">Yeah - I&#39;m in there now trying. Uhhh - you are totally=
 part of the mailing list. I have no idea what is going on. Anyone with mor=
e mailman foo than I have have any ideas/want to be an admin?<br></div><div=
 class=3D"gmail_extra"><br><div class=3D"gmail_quote">On Tue, May 19, 2015 =
at 1:40 PM, Oliver Keyes <span dir=3D"ltr">&lt;<a href=3D"mailto:okeyes@wik=
imedia.org" target=3D"_blank">okeyes@wikimedia.org</a>&gt;</span> wrote:<br=
><blockquote class=3D"gmail_quote" style=3D"margin:0 0 0 .8ex;border-left:1=
px #ccc solid;padding-left:1ex">This is ridiculous. Can someone fix our per=
missions? :/<br>
<br>
---------- Forwarded message ----------<br>
From:=C2=A0 &lt;<a href=3D"mailto:wikimedia-search-private-bounces@lists.wi=
kimedia.org">wikimedia-search-private-bounces@lists.wikimedia.org</a>&gt;<b=
r>
Date: 19 May 2015 at 13:35<br>
Subject: Your message to Wikimedia-search-private awaits moderator approval=
<br>
To: <a href=3D"mailto:okeyes@wikimedia.org">okeyes@wikimedia.org</a><br>
<br>
<br>
Your mail to &#39;Wikimedia-search-private&#39; with the subject<br>
<br>
=C2=A0 =C2=A0 Re: [Wikimedia-search-private] Metrics/measurement and James<=
br>
<br>
Is being held until the list moderator can review it for approval.<br>
<br>
The reason it is being held:<br>
<br>
=C2=A0 =C2=A0 Post by non-member to a members-only list<br>
<br>
Either the message will get posted to the list, or you will receive<br>
notification of the moderator&#39;s decision.=C2=A0 If you would like to ca=
ncel<br>
this posting, please visit the following URL:<br>
<br>
=C2=A0 =C2=A0 <a href=3D"https://lists.wikimedia.org/mailman/confirm/wikime=
dia-search-private/721b351ba0c4585b7e161c43c381ac8f80fa92fa" target=3D"_bla=
nk">https://lists.wikimedia.org/mailman/confirm/wikimedia-search-private/72=
1b351ba0c4585b7e161c43c381ac8f80fa92fa</a><br>
<span class=3D"HOEnZb"><font color=3D"#888888"><br>
<br>
<br>
--<br>
Oliver Keyes<br>
Research Analyst<br>
Wikimedia Foundation<br>
<br>
_______________________________________________<br>
Wikimedia-search-private mailing list<br>
<a href=3D"mailto:Wikimedia-search-private@lists.wikimedia.org">Wikimedia-s=
earch-private@lists.wikimedia.org</a><br>
<a href=3D"https://lists.wikimedia.org/mailman/listinfo/wikimedia-search-pr=
ivate" target=3D"_blank">https://lists.wikimedia.org/mailman/listinfo/wikim=
edia-search-private</a><br>
</font></span></blockquote></div><br></div>

--bcaec54fb4e2709bc0051672e1e8--
--bcaec54fb4e2709bc6051672e1ea
Content-Type: image/png; name="okeyes in list.png"
Content-Disposition: attachment; filename="okeyes in list.png"
Content-Transfer-Encoding: base64
X-Attachment-Id: f_i9vm2pe50

iVBORw0KGgoAAAANSUhEUgAAAtsAAALYCAIAAAAihqlRAAAAA3NCSVQICAjb4U/gAAAAGXRFWHRT
b2Z0d2FyZQBnbm9tZS1zY3JlZW5zaG907wO/PgAAIABJREFUeJzs3Xd4FNXaAPB3tqdseoM0SCCh
htAChBapQUCKoBQRlCJwUQQBQVApIipKEQVRigiIQBA/amgCASmCEqpEipBAICTZ2d5mZ873RzY9
WwibbDa8v8fnudk5Z04N97yZcpYihACqSTTXDLPfN+y9TERuoFZCVD/J8q/EbX2c3SyEEEKoKlEY
--snip--
+HgZNjmBAAAAAElFTkSuQmCC
--bcaec54fb4e2709bc6051672e1ea--

and here is the bounce:

Delivered-To: neverett@wikimedia.org
Received: by 10.202.191.212 with SMTP id p203csp906171oif;
        Tue, 19 May 2015 10:46:25 -0700 (PDT)
X-Received: by 10.229.184.2 with SMTP id ci2mr16172647qcb.2.1432057585772;
        Tue, 19 May 2015 10:46:25 -0700 (PDT)
Return-Path: <wikimedia-search-private-bounces@lists.wikimedia.org>
Received: from polonium.wikimedia.org (polonium.wikimedia.org. [208.80.154.90])
        by mx.google.com with ESMTP id x9si14684400qcs.32.2015.05.19.10.46.25
        for <neverett@wikimedia.org>;
        Tue, 19 May 2015 10:46:25 -0700 (PDT)
Received-SPF: pass (google.com: domain of wikimedia-search-private-bounces@lists.wikimedia.org designates 208.80.154.90 as permitted sender)
Authentication-Results: mx.google.com;
       spf=pass (google.com: domain of wikimedia-search-private-bounces@lists.wikimedia.org designates 208.80.154.90 as permitted sender) smtp.mail=wikimedia-search-private-bounces@lists.wikimedia.org;
       dkim=pass header.i=@lists.wikimedia.org
Received: from lists.wikimedia.org ([2620:0:861:1::2]:34362)
	by polonium.wikimedia.org with esmtp (Exim 4.82)
	(envelope-from <wikimedia-search-private-bounces@lists.wikimedia.org>)
	id 1Yulaz-0004rW-E0
	for neverett@wikimedia.org; Tue, 19 May 2015 17:46:25 +0000
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=lists.wikimedia.org; s=wikimedia;
	h=Sender:List-Id:Date:Message-ID:To:From:Subject:Content-Transfer-Encoding:Content-Type:MIME-Version; bh=EYgX+NBYqUTrCAH9tbHYA+GfwXqg70HzwGTgRUIxPpU=;
	b=RCewiNMba12GsfbYETHlCBSyyGxt0UXfVYnLQbK+CoMS44aiHN6EsyBfeQlCPi21jkePlPC8ELSTKvFGBum3XmOpSYONLIH0BFhRDa17MVighpcMwjPpo2Dt08B9Bwo+SInv+qioFVKD5zhOQRbgUgESQSIOeH74wEDhwDdmCek=;
Received: from localhost ([::1]:38982 helo=sodium.wikimedia.org)
	by sodium.wikimedia.org with esmtp (Exim 4.71)
	(envelope-from <wikimedia-search-private-bounces@lists.wikimedia.org>)
	id 1Yulay-0006sp-Rb
	for neverett@wikimedia.org; Tue, 19 May 2015 17:46:25 +0000
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64
Subject: =?utf-8?q?Your_message_to_Wikimedia-search-private_awaits_modera?=
 =?utf-8?q?tor_approval?=
From: wikimedia-search-private-bounces@lists.wikimedia.org
To: neverett@wikimedia.org
Message-ID: <mailman.97.1432057575.17898.wikimedia-search-private@lists.wikimedia.org>
Date: Tue, 19 May 2015 17:46:15 +0000
Precedence: bulk
X-BeenThere: wikimedia-search-private@lists.wikimedia.org
X-Mailman-Version: 2.1.13
List-Id: Internal communications for WMF search and discovery team
	<wikimedia-search-private.lists.wikimedia.org>
X-List-Administrivia: yes
Sender: wikimedia-search-private-bounces@lists.wikimedia.org
Errors-To: wikimedia-search-private-bounces@lists.wikimedia.org

WW91ciBtYWlsIHRvICdXaWtpbWVkaWEtc2VhcmNoLXByaXZhdGUnIHdpdGggdGhlIHN1YmplY3QK
CiAgICBSZTogW1dpa2ltZWRpYS1zZWFyY2gtcHJpdmF0ZV0gRndkOiBZb3VyIG1lc3NhZ2UgdG8K
V2lraW1lZGlhLXNlYXJjaC1wcml2YXRlIGF3YWl0cyBtb2RlcmF0b3IgYXBwcm92YWwKCklzIGJl
aW5nIGhlbGQgdW50aWwgdGhlIGxpc3QgbW9kZXJhdG9yIGNhbiByZXZpZXcgaXQgZm9yIGFwcHJv
dmFsLgoKVGhlIHJlYXNvbiBpdCBpcyBiZWluZyBoZWxkOgoKICAgIFBvc3QgYnkgbm9uLW1lbWJl
ciB0byBhIG1lbWJlcnMtb25seSBsaXN0CgpFaXRoZXIgdGhlIG1lc3NhZ2Ugd2lsbCBnZXQgcG9z
dGVkIHRvIHRoZSBsaXN0LCBvciB5b3Ugd2lsbCByZWNlaXZlCm5vdGlmaWNhdGlvbiBvZiB0aGUg
bW9kZXJhdG9yJ3MgZGVjaXNpb24uICBJZiB5b3Ugd291bGQgbGlrZSB0byBjYW5jZWwKdGhpcyBw
b3N0aW5nLCBwbGVhc2UgdmlzaXQgdGhlIGZvbGxvd2luZyBVUkw6CgogICAgaHR0cHM6Ly9saXN0
cy53aWtpbWVkaWEub3JnL21haWxtYW4vY29uZmlybS93aWtpbWVkaWEtc2VhcmNoLXByaXZhdGUv
ZjY2NTY5ZDBmYzc2OGExOTgxMjdhODY3ZTYxZDE3MDI3MTQxNmI5MwoK

The moderator interface claims that the message was held because it was sent by a non-member. But I'm a member on membership page and I get the emails.

Sadads added a subscriber: Sadads.May 19 2015, 6:35 PM

We are experiencing the same thing with the Wikipedia-Library lists: its even rejecting admins of the list (for example, jorlowitz@gmail.com ).

Yeah - it rejected mine today and I'm an admin in that I know that admin password. I don't think it connects my email to my web actions though.

Dzahn added a subscriber: Dzahn.EditedMay 19 2015, 7:12 PM

fwiw, as manybubbles said there is no user flag "admin" or something that influences how mails are treated.

"being an admin" just means knowing the password for the web ui

JohnLewis raised the priority of this task from High to Unbreak Now!.May 19 2015, 7:18 PM

This seems to affect wikidata, a random list I just created now and reported on IRC.

Risker added a subscriber: Risker.May 19 2015, 7:18 PM
Risker added a comment.EditedMay 19 2015, 7:26 PM

Also occurring on (non-public, non-archiving, subscriber-only) checkuser-L - this is flat-out rejecting emails from subscribers, not sending to moderation.

Not occurring on some other non-public lists, such as functionaries-en-L (which allows moderation and is an archiving list but is non-public) or oversight-L (non-public, subscriber-only, non-archiving).

Possible issue identified and working on a fix. Likely a permissions issue. Will keep updated.

saper added a subscriber: saper.May 19 2015, 7:39 PM

Also occurring on (non-public, non-archiving, subscriber-only) checkuser-L - this is flat-out rejecting emails from subscribers, not sending to moderation.
Not occurring on some other non-public lists, such as functionaries-en-L (which allows moderation and is an archiving list but is non-public) or oversight-L (non-public, subscriber-only, non-archiving).

We have now confirmed that it is also affecting oversight-L as well. It seems it will allow the first email in a "new" thread but will reject replies to existing threads on both checkuser-L and oversight-L.

For the record problem on board-elections too [though I imagine if you've found the issue you can figure it out, dropping here just in case it ends up being needed for further troubleshooting].

saper added a comment.May 19 2015, 9:01 PM

I tried a new thread and a reply on checkuser-l and they got rejected as described in this bug.

JohnLewis closed this task as Resolved.May 19 2015, 9:06 PM

After countless attempts and searching the issues was linked to a broken configuration change merged last month with no restart so this was not identified at the time of merge.

https://gerrit.wikimedia.org/r/#/c/212188/ revert it.

I was the original patch maker so I am ultimately at fault but that was a year ago so! Thanks to @RobH for the merging and fixing as well as assisting in debug and @Dzahn too.

KTC added a subscriber: KTC.May 19 2015, 9:09 PM

Wondering if the issue reported by at least two people that they receive empty digests is also kind of related to configuration patches?
See e.g. https://lists.wikimedia.org/pipermail/wikitech-l/2015-May/081684.html

Wondering if the issue reported by at least two people that they receive empty digests is also kind of related to configuration patches?
See e.g. https://lists.wikimedia.org/pipermail/wikitech-l/2015-May/081684.html

No as the patch only took effect today. Also digests seem fine for me so it is unrelated.

Sadads removed a subscriber: Sadads.May 19 2015, 11:12 PM