Page MenuHomePhabricator
Feed Advanced Search

Oct 10 2018

DavidBrooks added a comment to T204669: Slow access to Special:Contributions on mediawiki.org (due to enabling actor table WRITE_BOTH mode).

I don't know if this is late to the game, but from the perspective of one who uses the http API: in the past 2 weeks or so, on en.wikipedia.org, a multi-user "usercontribs" query went from always returning immediately (sub-second) to always timing out. Is this change intended to fix that?

Oct 10 2018, 6:48 PM · MW-1.33-notes (1.33.0-wmf.8; 2018-12-11), Core Platform Team Workboards (Done with CPT), MW-1.32-notes (WMF-deploy-2018-10-16 (1.32.0-wmf.26)), Core Platform Team (Needs Cleaning - Security, stability, performance, and scalability (TEC1)), Patch-For-Review, Regression, MediaWiki-Special-pages, Performance
DavidBrooks added a comment to T33197: Implement revision filter by namespace for big wikis in "miser mode".

Your issue isn't really related to this task. But I suspect it'll be fixed by https://gerrit.wikimedia.org/r/c/mediawiki/core/+/461440, when that gets merged.

Oct 10 2018, 12:18 AM · MediaWiki-Special-pages

Oct 9 2018

DavidBrooks added a comment to T33197: Implement revision filter by namespace for big wikis in "miser mode".

I was sent here from a thread in mediawiki.org API talk:Usercontribs. On the English Wikipedia, in recent days, a simple usercontribs list request with two ucusers has changed from always responding immediately (sub-second) to always timing out. Here's the actual URL I recently tried:
GET /w/api.php?action=query&format=xml&list=usercontribs&ucuser=DavidBrooks%7CDavidBrooks-AWB&uclimit=20&ucnamespace=0&ucprop=title%7Ctimestamp%7Ccomment%7Cflags&continue= HTTP/1.1

Oct 9 2018, 2:12 PM · MediaWiki-Special-pages

Jul 18 2015

DavidBrooks added a comment to T106189: Cannot connect to svn repository.

I thought that might be the case. Just wanted to be sure you were aware.

Jul 18 2015, 4:49 AM · AutoWikiBrowser

Jul 17 2015

DavidBrooks created T106189: Cannot connect to svn repository.
Jul 17 2015, 9:54 PM · AutoWikiBrowser

Jul 15 2015

DavidBrooks added a comment to T105839: Newtonsoft.Json assembly manifest doesnt match assembly reference.

Repro steps work - thanks for the quick fix.

Jul 15 2015, 5:25 PM · AutoWikiBrowser

Jul 14 2015

DavidBrooks added a comment to T105839: Newtonsoft.Json assembly manifest doesnt match assembly reference.

Confirmed: I just downloaded version 5700. When trying to switch projects, the UI says it cannot load Newtonsoft.Json, version 7.0.0.0. The version in the download zip is 6.0.8.18111.

Jul 14 2015, 9:29 PM · AutoWikiBrowser