Page MenuHomePhabricator

IndyJr
User

Projects

User does not belong to any projects.

Today

  • Clear sailing ahead.

Tomorrow

  • Clear sailing ahead.

Wednesday

  • Clear sailing ahead.

User Details

User Since
Feb 29 2016, 12:14 AM (248 w, 8 h)
Availability
Available
LDAP User
Unknown
MediaWiki User
IndyJr [ Global Accounts ]

Recent Activity

Oct 10 2019

IndyJr added a comment to T233127: HTTP 404 error in VE possibly when confronted with an edit conflict.

Update: I think I found the bug in RESTBase. I deployed the fix yesterday and so far so good. I will leave RB logging on until Monday to make sure the problem is indeed fixed.

In the meantime, I also found how to reproduce the bug, so if there are any testers willing to try it, feel free to test it out. The bug essentially happens on a first VE-edit of a page (that is, open the browser, load a page, click on edit) for pages that have been last edited more than 24h prior.

Oct 10 2019, 3:21 PM · User-Ryasmeen, Platform Team Workboards (Clinic Duty Team), RESTBase, MW-1.35-notes (1.35.0-wmf.1; 2019-10-08), MW-1.34-notes (1.34.0-wmf.25; 2019-10-01), VisualEditor (Current work)

Sep 24 2019

IndyJr added a comment to T233320: VisualEditor <-> RESTBase communication and ETags.

Is there any debugging tool that can be activated and can record all client/server swingers data in case of hitting the error?

Sep 24 2019, 8:03 PM · MW-1.35-notes (1.35.0-wmf.3; 2019-10-22), MW-1.34-notes (1.34.0-wmf.24; 2019-09-24), Patch-For-Review, VisualEditor (Current work), User-mobrovac, Platform Team Workboards (Clinic Duty Team), RESTBase

Sep 23 2019

IndyJr added a comment to T233127: HTTP 404 error in VE possibly when confronted with an edit conflict.

It is evident the bug has not been fixed, it has only decreased frequency.

Sep 23 2019, 9:24 AM · User-Ryasmeen, Platform Team Workboards (Clinic Duty Team), RESTBase, MW-1.35-notes (1.35.0-wmf.1; 2019-10-08), MW-1.34-notes (1.34.0-wmf.25; 2019-10-01), VisualEditor (Current work)

Sep 22 2019

IndyJr added a comment to T233127: HTTP 404 error in VE possibly when confronted with an edit conflict.

I no longer observed that bug after they (developers) claimed to have fixed it, but if it still persists today evidently the underlying problem remains.

Sep 22 2019, 10:42 PM · User-Ryasmeen, Platform Team Workboards (Clinic Duty Team), RESTBase, MW-1.35-notes (1.35.0-wmf.1; 2019-10-08), MW-1.34-notes (1.34.0-wmf.25; 2019-10-01), VisualEditor (Current work)

Sep 16 2019

IndyJr added a comment to T230272: 404 error when using VisualEditor: apierror-visualeditor-docserver-http.

The problem I reported still go on, on random pages, and is not reproducible. The only workaround I found to don't lose job until then, is to copy and paste into a new window that NOT recovers the unsaved work (because otherwise it doesn't save it again with the same error message).

Sep 16 2019, 9:52 AM · User-notice, Platform Team Workboards (Clinic Duty Team), RESTBase, VisualEditor (Current work)

Aug 10 2019

IndyJr added a comment to T230272: 404 error when using VisualEditor: apierror-visualeditor-docserver-http.

Try to made more deleting lines and modify wikilink. The problem cannot reproduce at every single edit, but it appears very frequently.

Aug 10 2019, 8:07 PM · User-notice, Platform Team Workboards (Clinic Duty Team), RESTBase, VisualEditor (Current work)

Aug 1 2019

IndyJr moved T224381: Ignore external /wikilinks etc. in Advanced Settings too from Backlog to Feature Requests on the AutoWikiBrowser board.
Aug 1 2019, 8:54 PM · AutoWikiBrowser

May 26 2019

IndyJr created T224381: Ignore external /wikilinks etc. in Advanced Settings too.
May 26 2019, 10:47 PM · AutoWikiBrowser