Page MenuHomePhabricator

TheROFL98
User

Projects

User does not belong to any projects.

Today

  • Clear sailing ahead.

Tomorrow

  • Clear sailing ahead.

Tuesday

  • Clear sailing ahead.

User Details

User Since
Feb 27 2019, 9:18 AM (28 w, 3 d)
Availability
Available
LDAP User
Unknown
MediaWiki User
TheROFL98 [ Global Accounts ]

Recent Activity

Mar 22 2019

TheROFL98 added a comment to T218590: VisualEditor fails when switching back-and-forth between visual and wikitext modes on a third-party wiki.

I've checked the RESTbase Docs in https://wiki.therofl98.co/api/rest_v1/ and tested conversion from HTML to Wikitext. When I input HTML, page title, and revision, it returns a 400 with a message similar to

{
  "type": "https://mediawiki.org/wiki/HyperSwitch/errors/bad_request",
  "method": "post",
  "detail": "No or invalid If-Match header supplied, or missing mw:TimeUuid meta element in the supplied HTML.",
  "uri": "/wiki.therofl98.co/v1/transform/html/to/wikitext/test/1"
}
Mar 22 2019, 3:38 PM · VisualEditor

Mar 18 2019

TheROFL98 added a comment to T218590: VisualEditor fails when switching back-and-forth between visual and wikitext modes on a third-party wiki.

I'm having this problem on a self hosted MediaWiki installation, located here. To reproduce, you begin editing a page in VisualEditor. You make some edits on the page, but don't save it just yet. You switch to the Wikitext editor to see how that version looks, and make adjustments. You then switch back to Visual to see how it looks, and make further adjustments. After this, when you try to switch to Wikitext, Error loading data from server: apierror-visualeditor-docserver-http. pops up, and the RESTbase log reports something similar to this:

{"name":"restbase","hostname":"UBUNTU","pid":10565,"level":40,"msg":"Client did not supply etag, fallback to mw:TimeUuid meta element","root_req":{"method":"post","uri":"/wiki.therofl98.co/v1/transform/html/to/wikitext/User%3ATherofl98%2Fsandbox/2698","headers":{"content-length":"3865","content-type":"multipart/form-data; boundary=------------------------5ae5598f4d8291f0","if-match":"null","user-agent":"VisualEditor-MediaWiki/1.33.0-alpha","api-user-agent":"VisualEditor-MediaWiki/1.33.0-alpha","x-client-ip":"::ffff:127.0.0.1","x-forwarded-for":"2601:241:4101:6b97:d958:12de:3ce0:3c49, ::ffff:127.0.0.1","x-request-id":"c793ac00-41e9-11e9-95ba-97b55f560dd8","x-request-class":"internal"}},"request_id":"c793ac00-41e9-11e9-95ba-97b55f560dd8","api_path":"/wiki.therofl98.co/v1/transform/html/to/wikitext{/title}{/revision}","levelPath":"warn/parsoid/etag","time":"2019-03-08T21:33:14.317Z","v":0}
Mar 18 2019, 10:30 PM · VisualEditor
TheROFL98 created T218590: VisualEditor fails when switching back-and-forth between visual and wikitext modes on a third-party wiki.
Mar 18 2019, 3:45 PM · VisualEditor

Mar 4 2019

TheROFL98 added a comment to T217423: SocialProfile Database Error.

Are you sure you downloaded the patch correctly? The line numbers in this error message don't line up with what they're supposed to be.

Mar 4 2019, 6:03 AM · Social-Tools, SocialProfile

Mar 2 2019

TheROFL98 added a comment to T217423: SocialProfile Database Error.

It appears it's now giving me a new error.

Mar 2 2019, 1:24 AM · Social-Tools, SocialProfile

Mar 1 2019

TheROFL98 created T217423: SocialProfile Database Error.
Mar 1 2019, 4:25 PM · Social-Tools, SocialProfile