Page MenuHomePhabricator

dan-nl (dan entous)
User

Projects

User does not belong to any projects.

Today

  • Clear sailing ahead.

Tomorrow

  • Clear sailing ahead.

Thursday

  • Clear sailing ahead.

User Details

User Since
Oct 11 2014, 8:58 AM (510 w, 3 d)
Availability
Available
LDAP User
Unknown
MediaWiki User
Dan-nl [ Global Accounts ]

Recent Activity

Jun 13 2015

dan-nl renamed T102136: MimeMagic doesn't like it when webservers return content-type: image/pjpeg from gwtoolset doesn't like it when webservers return content-type: image/pjpeg to MimeMagic doesn't like it when webservers return content-type: image/pjpeg.
Jun 13 2015, 5:28 AM · WMF-deploy-2015-06-16_(1.26wmf10), MW-1.26-release, Patch-For-Review, MediaWiki-extensions-GWToolset, Multimedia

Jun 11 2015

dan-nl added a comment to T102136: MimeMagic doesn't like it when webservers return content-type: image/pjpeg.

GWToolset uses GWToolset\Handlers:UploadHandler:getFileExtension() to attempt to determine the media file’s extension. it uses php’s pathinfo and mediawiki’s MimeMagic to determine a valid file extension. if either of those methods fails, the file extension is assumed to be invalid.

Jun 11 2015, 7:34 PM · WMF-deploy-2015-06-16_(1.26wmf10), MW-1.26-release, Patch-For-Review, MediaWiki-extensions-GWToolset, Multimedia
dan-nl added a comment to T101513: Please add <http://www.limis.lt/> to $wgCopyUploadsDomains.

sorry, didn’t know what the acronymn meant: Server Admin Log (SAL). thanks for your help.

Jun 11 2015, 12:06 AM · Patch-For-Review, Wikimedia-Site-requests, Commons
dan-nl added a comment to T101513: Please add <http://www.limis.lt/> to $wgCopyUploadsDomains.

SAL?

Jun 11 2015, 12:01 AM · Patch-For-Review, Wikimedia-Site-requests, Commons

Jun 10 2015

dan-nl added a comment to T101513: Please add <http://www.limis.lt/> to $wgCopyUploadsDomains.

i just checked both beta and production and the whitelist config change appears in both environments. was the merged patch also deployed to production?

Jun 10 2015, 11:51 PM · Patch-For-Review, Wikimedia-Site-requests, Commons
dan-nl added a comment to T101513: Please add <http://www.limis.lt/> to $wgCopyUploadsDomains.

wat? config changes get automatically sent to beta once they're merged in Gerrit, sure, but production requires a deployer to log into a deployment server, pull the change, and push it to the servers. Approving mediawiki-config patches in Gerrit but not deploying them to production can cause issues and make you unpopular with the next person that does want to deploy a config change.

Jun 10 2015, 2:56 PM · Patch-For-Review, Wikimedia-Site-requests, Commons
dan-nl added a comment to T101513: Please add <http://www.limis.lt/> to $wgCopyUploadsDomains.

based on past experience, once these config` patches are merged, the changes are available on beta and production in about 15 minutes. there was no need for a SWAT or regular deploy.

Jun 10 2015, 2:33 PM · Patch-For-Review, Wikimedia-Site-requests, Commons

Feb 26 2015

Steinsplitter awarded rEGWT1df24404d37b: Removed the default tracking category, GWToolset Batch Upload. a Yellow Medal token.
Feb 26 2015, 7:05 PM
dan-nl updated subscribers of T90887: GWT created a page that had "�" in the text.
Feb 26 2015, 5:29 PM · Commons, MediaWiki-extensions-GWToolset, Multimedia
dan-nl added a comment to T90887: GWT created a page that had "�" in the text.

@MarkTraceur,
it looks like there was a problem with the original metadata that fæ cleaned-up; see this revision comparison. but i’d double-check with fæ to make sure. not sure how to add @fæ to this task. will @Fae do it?

Feb 26 2015, 5:28 PM · Commons, MediaWiki-extensions-GWToolset, Multimedia

Feb 14 2015

dan-nl added a comment to T88758: Undertake a mass upload of 14 million files (1.5 TB) to Commons.

Would a 14 million entry XML file be too big?

yes, as @Reedy already mentioned. i believe the largest xml file i used during testing was a 10,000 record file that was 58.7mb in size, which is a good size to limit each xml file to - 10,000 records.

Feb 14 2015, 4:02 AM · Commons, SRE, Performance Issue, MediaWiki-extensions-GWToolset, Multimedia

Feb 4 2015

dan-nl added a comment to T87104: White list request: www.doria.fi by National Library of Finland.

@Artturimatias,
might be good to open a new task for the issue. in any case:

  • i tested the url by running curl -i http://www.doria.fi/bitstream/10024/92051/1/1201003266_1.jpg and got a response that seems like it should work.
    • is the error message you mention the complete error message?
  • can you upload a small sample of the xml file you’re using?
    • and a link to the metadata mapping you created?
  • i don’t see any GWToolset uploads with your username in the beta commons Special Log, so i assume that means that you’re getting the error message as you setup the batch job - correct?
Feb 4 2015, 6:01 AM · Patch-For-Review, Shell, Wikimedia-Site-requests

Feb 2 2015

dan-nl added a comment to T87104: White list request: www.doria.fi by National Library of Finland.

i suggest you try uploading a few maps on commons beta ahead of the hackathon so that any issues you might run into could be addressed as soon as possible.

Feb 2 2015, 10:30 AM · Patch-For-Review, Shell, Wikimedia-Site-requests

Jan 31 2015

dan-nl closed T75732: Updating broken 'request' link at GWToolset as Resolved.
Jan 31 2015, 4:30 PM · Patch-For-Review, Multimedia, MediaWiki-extensions-GWToolset
dan-nl closed T88094: Job runner not running in deployment-prep as Resolved.

thanks for taking care of this @yuvipanda!

Jan 31 2015, 4:40 AM · Patch-For-Review, WMF-JobQueue, Release-Engineering-Team, Beta-Cluster-Infrastructure

Jan 29 2015

dan-nl added a comment to T87478: Provisioning MediaWiki-Vagrant fails with "Could not set 'file' on ensure: Is a directory - /etc/hhvm/php.ini".

i see. thanks, but how is MW-Vagrant determining where to get the apt-get package for hhvm?

Jan 29 2015, 8:33 PM · SRE, Patch-For-Review, MediaWiki-Vagrant
dan-nl added a comment to T87478: Provisioning MediaWiki-Vagrant fails with "Could not set 'file' on ensure: Is a directory - /etc/hhvm/php.ini".

i agree, that ideally this would be fixed in the hhvm package, but it seems that this issue has existed for some time. i checked out a commit hash from 25 september 2014, 7447c9804b947b4b7eba9af1d0dc93828d59bed9, and still saw this issue when creating a new vm.

Jan 29 2015, 6:31 AM · SRE, Patch-For-Review, MediaWiki-Vagrant

Jan 27 2015

dan-nl added a comment to T87478: Provisioning MediaWiki-Vagrant fails with "Could not set 'file' on ensure: Is a directory - /etc/hhvm/php.ini".

installed hhvm version: 3.5.0-trusty in an unpuppetized vagrant instance and it installs php.ini in /etc/hhvm/php.ini. it seems that the issue is with the pkg version 3.3.1+dfsg1-1+wm3, which installs php.ini in /etc/hhvm/php.ini/php.ini. i don’t know how or where this needs to be fixed or reported.

Jan 27 2015, 1:40 AM · SRE, Patch-For-Review, MediaWiki-Vagrant

Jan 26 2015

dan-nl added a comment to T87458: Vagrant fresh install fails to run composer: php5 not found?.

this commit based on this patch seems to have created the issue.

Jan 26 2015, 5:45 AM · User-bd808, Patch-For-Review, MediaWiki-Vagrant

Jan 23 2015

dan-nl added a comment to T87040: GWT infinite loops with wmf's new hhvm job runners.

@Bawolff,
would you mind setting that cherry picked merge up?

Jan 23 2015, 1:36 PM · Patch-For-Review, Multimedia, MediaWiki-extensions-GWToolset
dan-nl added a comment to T87040: GWT infinite loops with wmf's new hhvm job runners.

@Tounoki,
you should be able to run a small test on beta first. if your test works on beta, then “in theory” it should work on production once GWToolset 0.3.8 (1fd5c4d) 16:55, 22 January 2015 is deployed there. you can check this page in production and look for GWToolset to see which version is on production.

Jan 23 2015, 9:44 AM · Patch-For-Review, Multimedia, MediaWiki-extensions-GWToolset

Jan 22 2015

dan-nl added a comment to T87040: GWT infinite loops with wmf's new hhvm job runners.

@Kelson,
once https://gerrit.wikimedia.org/r/#/c/186241/ is deployed to production you can try the upload again. i suggest using a small subset to start and then the rest once you're able to verify that all is well.

Jan 22 2015, 5:02 PM · Patch-For-Review, Multimedia, MediaWiki-extensions-GWToolset
dan-nl updated subscribers of T86699: Please add <*.bnf.fr> to the wgCopyUploadsDomains whitelist of Wikimedia Commons.

fyi: just added @hashar to the gerrit patch. hopefully he or @Reedy can get to it soon.

Jan 22 2015, 11:56 AM · Patch-For-Review, Wikimedia-Site-requests, Shell

Jan 21 2015

dan-nl added a comment to T87040: GWT infinite loops with wmf's new hhvm job runners.

@Krenair,
thanks for checking it.

Jan 21 2015, 2:45 PM · Patch-For-Review, Multimedia, MediaWiki-extensions-GWToolset

Jan 20 2015

dan-nl added a comment to T87040: GWT infinite loops with wmf's new hhvm job runners.

is the constant PHP_SAPI defined in production?
when a job is run by the job runner, is that constant set to 'cli'?

Jan 20 2015, 7:15 AM · Patch-For-Review, Multimedia, MediaWiki-extensions-GWToolset

Jan 14 2015

dan-nl added a comment to T86699: Please add <*.bnf.fr> to the wgCopyUploadsDomains whitelist of Wikimedia Commons.

@Steinsplitter,

Jan 14 2015, 5:04 PM · Patch-For-Review, Wikimedia-Site-requests, Shell
dan-nl added a comment to T86699: Please add <*.bnf.fr> to the wgCopyUploadsDomains whitelist of Wikimedia Commons.

Does this need to be discussed somewhere, e.g. on commons?

not always.

Jan 14 2015, 11:27 AM · Patch-For-Review, Wikimedia-Site-requests, Shell

Dec 15 2014

dan-nl added a comment to T75732: Updating broken 'request' link at GWToolset.

the fix has been deployed to production. are you okay with closing this task or is there something i may have missed?

Dec 15 2014, 8:58 AM · Patch-For-Review, Multimedia, MediaWiki-extensions-GWToolset

Dec 7 2014

dan-nl added a comment to T76450: Upload stopps regularly.

thanks hoo,

Dec 7 2014, 2:29 AM · Multimedia, MediaWiki-extensions-GWToolset

Dec 3 2014

dan-nl reopened T70285: GWToolset fails to upload files and throws no warning as "Open".
Dec 3 2014, 10:25 AM · Commons, Multimedia, MediaWiki-extensions-GWToolset
dan-nl updated subscribers of T76450: Upload stopps regularly.
Dec 3 2014, 10:21 AM · Multimedia, MediaWiki-extensions-GWToolset
dan-nl merged task T76451: GWToolset uploads get stuck into T76450: Upload stopps regularly.
Dec 3 2014, 10:21 AM · SRE, MediaWiki-extensions-GWToolset, Multimedia
dan-nl merged task T70285: GWToolset fails to upload files and throws no warning into T76450: Upload stopps regularly.
Dec 3 2014, 10:21 AM · Commons, Multimedia, MediaWiki-extensions-GWToolset
dan-nl added a comment to T76450: Upload stopps regularly.

this seems to be a job runner/job queue issue.

  • is there someone on the ops team who could investigate it?
  • is there a way to tell when the job runner is having a problem?
  • is there a way to see which job's are in the job queue?
Dec 3 2014, 9:52 AM · Multimedia, MediaWiki-extensions-GWToolset
dan-nl added projects to T76450: Upload stopps regularly: acl*sre-team, Multimedia.
Dec 3 2014, 9:47 AM · Multimedia, MediaWiki-extensions-GWToolset