ferdbold (Frédéric Bolduc)
Software Engineer (Contractor), Editing/VisualEditor

Projects

Today

  • Clear sailing ahead.

Tomorrow

  • Clear sailing ahead.

Sunday

  • Clear sailing ahead.

User Details

User Since
Mar 20 2015, 6:43 PM (117 w, 6 d)
Availability
Available
IRC Nick
ferdbold
LDAP User
Unknown
MediaWiki User
Ferdbold

I work on Graphs

Recent Activity

Nov 23 2016

ferdbold added a comment to T151262: Number of columns for X and Y values for a graph keep increasing every time I open the dialog for empty <graph> node.

Nice catch, I'll look into this ASaP

Nov 23 2016, 2:07 PM · Graphs, Discovery, VisualEditor

Nov 19 2016

ferdbold added a subtask for T119233: [Objective] It's easier to create and edit charts from within VisualEditor: T151127: Display graph preview while editing in dialog.
Nov 19 2016, 9:00 PM · User-Ryasmeen, Category, Epic, Graphs, VisualEditor
ferdbold added a parent task for T151127: Display graph preview while editing in dialog: T119233: [Objective] It's easier to create and edit charts from within VisualEditor.
Nov 19 2016, 9:00 PM · VisualEditor, Patch-For-Review, Graphs
ferdbold created T151127: Display graph preview while editing in dialog.
Nov 19 2016, 9:00 PM · VisualEditor, Patch-For-Review, Graphs
ferdbold closed T109667: VisualEditor throws exception while trying to open empty <graph> node, a subtask of T119233: [Objective] It's easier to create and edit charts from within VisualEditor, as Resolved.
Nov 19 2016, 8:59 PM · User-Ryasmeen, Category, Epic, Graphs, VisualEditor
ferdbold closed T109667: VisualEditor throws exception while trying to open empty <graph> node as Resolved.
Nov 19 2016, 8:59 PM · Verified-in-Phase2, Verified-in-Phase0, Verified, MW-1.29-release (WMF-deploy-2016-11-29_(1.29.0-wmf.4)), Graph-VisualEditor, Graphs, VisualEditor
ferdbold added a comment to T109667: VisualEditor throws exception while trying to open empty <graph> node.

Cannot reproduce anymore on mediawiki.org, closing this for now.

Nov 19 2016, 8:59 PM · Verified-in-Phase2, Verified-in-Phase0, Verified, MW-1.29-release (WMF-deploy-2016-11-29_(1.29.0-wmf.4)), Graph-VisualEditor, Graphs, VisualEditor
ferdbold closed T118896: Graph does not appear in Read mode after saving the page as Resolved.
Nov 19 2016, 8:55 PM · Verified-in-Phase2, Verified-in-Phase0, Verified, MW-1.29-release (WMF-deploy-2016-11-29_(1.29.0-wmf.4)), Graphs, Graph-VisualEditor, VisualEditor
ferdbold closed T118896: Graph does not appear in Read mode after saving the page, a subtask of T119233: [Objective] It's easier to create and edit charts from within VisualEditor, as Resolved.
Nov 19 2016, 8:55 PM · User-Ryasmeen, Category, Epic, Graphs, VisualEditor
ferdbold added a comment to T118896: Graph does not appear in Read mode after saving the page.

I'm not seeing this happen anymore (graphs are regenerated by Graphoid fine on a VE save on mediawiki.org), so closing this.

Nov 19 2016, 8:55 PM · Verified-in-Phase2, Verified-in-Phase0, Verified, MW-1.29-release (WMF-deploy-2016-11-29_(1.29.0-wmf.4)), Graphs, Graph-VisualEditor, VisualEditor

Nov 18 2016

ferdbold created T151017: Errors when installing through apt-get.
Nov 18 2016, 2:22 AM · User-mobrovac, Mathoid

Nov 7 2016

ferdbold renamed T150151: Port ve.ui.TableWidget to OOUI from Port ve.ui.TableWidget to ooUI to Port ve.ui.TableWidget to OOUI.
Nov 7 2016, 4:18 AM · OOjs-UI
ferdbold added a watcher for OOjs-UI: ferdbold.
Nov 7 2016, 4:17 AM
ferdbold created T150151: Port ve.ui.TableWidget to OOUI.
Nov 7 2016, 4:17 AM · OOjs-UI

Sep 25 2016

ferdbold added a comment to T122347: Resizing a graph in VisualEditing mode will transform the JSON from block to inline.

This is due to the graph extension stylesheet not being loaded the first time a graph is created on a page, resulting in VE wrongly displaying them as blocks. According to the stylesheet graphs should always be displayed as an inline-block.

Sep 25 2016, 7:39 PM · MW-1.28-release (WMF-deploy-2016-10-04_(1.28.0-wmf.21)), Patch-For-Review, VisualEditor-MediaWiki, Graphs, VisualEditor
ferdbold claimed T122347: Resizing a graph in VisualEditing mode will transform the JSON from block to inline.
Sep 25 2016, 6:29 PM · MW-1.28-release (WMF-deploy-2016-10-04_(1.28.0-wmf.21)), Patch-For-Review, VisualEditor-MediaWiki, Graphs, VisualEditor

Apr 16 2016

ferdbold claimed T121895: Pasting text for a link label removes the link.
Apr 16 2016, 11:49 PM · MW-1.28-release (WMF-deploy-2016-09-06_(1.28.0-wmf.18)), VisualEditor-MediaWiki-Links, VisualEditor-CopyPaste, VisualEditor

Apr 13 2016

ferdbold added a comment to T121895: Pasting text for a link label removes the link.

Thinking of digging into this, is this up for grabs?

Apr 13 2016, 8:48 PM · MW-1.28-release (WMF-deploy-2016-09-06_(1.28.0-wmf.18)), VisualEditor-MediaWiki-Links, VisualEditor-CopyPaste, VisualEditor
ferdbold added a comment to T132612: api.php gives a 302 redirect to URL with '&*' appended, breaking CORS requests.

@Esanders I get those as well

Apr 13 2016, 6:49 PM · MW-1.27-release-notes, MW-1.27-release (WMF-deploy-2016-04-26_(1.27.0-wmf.22)), Wikimedia-General-or-Unknown, Operations
ferdbold updated the task description for T132612: api.php gives a 302 redirect to URL with '&*' appended, breaking CORS requests.
Apr 13 2016, 6:46 PM · MW-1.27-release-notes, MW-1.27-release (WMF-deploy-2016-04-26_(1.27.0-wmf.22)), Wikimedia-General-or-Unknown, Operations
ferdbold added a comment to T132612: api.php gives a 302 redirect to URL with '&*' appended, breaking CORS requests.

Just checked, this happens on enwiki as well, so it's probably been out there for a while now

Apr 13 2016, 6:44 PM · MW-1.27-release-notes, MW-1.27-release (WMF-deploy-2016-04-26_(1.27.0-wmf.22)), Wikimedia-General-or-Unknown, Operations
ferdbold created T132612: api.php gives a 302 redirect to URL with '&*' appended, breaking CORS requests.
Apr 13 2016, 6:25 PM · MW-1.27-release-notes, MW-1.27-release (WMF-deploy-2016-04-26_(1.27.0-wmf.22)), Wikimedia-General-or-Unknown, Operations

Apr 3 2016

ferdbold added a watcher for Maps (Kartographer): ferdbold.
Apr 3 2016, 8:12 PM

Apr 2 2016

ferdbold added a comment to T125761: Clicking "edit" for a graph of unsupported type crashes VisualEditor.

I'm not able to reproduce this issue on my end, but treemap not being in the Vega2 mark documentation gives me the impression that this stopped being supported in Vega2.

Apr 2 2016, 10:45 PM · Graphs, VisualEditor

Mar 31 2016

ferdbold updated subscribers of T120630: Refactor TableWidget to use a proper model.

Looking for review on this: @Esanders @Jdforrester-WMF ?

Mar 31 2016, 8:09 PM · MW-1.29-release (WMF-deploy-2016-11-08_(1.29.0-wmf.2)), Technical-Debt, VisualEditor, Graphs

Feb 24 2016

ferdbold added a comment to T126421: RESTBase fails to start up on MW-Vagrant.

dammit, found the problem. Dumb dumb me wasn't pulling the right repo (I was pulling /mediawiki instead of the mw-vagrant root).

Feb 24 2016, 5:07 AM · Services, Patch-For-Review, RESTBase, MediaWiki-Vagrant
ferdbold added a comment to T126421: RESTBase fails to start up on MW-Vagrant.

Nope, still no go. I effectively had a /: on line 7, but still after removing it and running vagrant reload and vagrant provision the same 503 error happens upon VE load.

Feb 24 2016, 4:05 AM · Services, Patch-For-Review, RESTBase, MediaWiki-Vagrant

Feb 21 2016

ferdbold added a comment to T126421: RESTBase fails to start up on MW-Vagrant.

It's not running, I'm getting curl: (7) Failed to connect to localhost port 7231: Connection refused

Feb 21 2016, 6:46 PM · Services, Patch-For-Review, RESTBase, MediaWiki-Vagrant

Feb 18 2016

ferdbold added a comment to T126421: RESTBase fails to start up on MW-Vagrant.

That's what I did, but it didn't fix it.

Feb 18 2016, 10:36 PM · Services, Patch-For-Review, RESTBase, MediaWiki-Vagrant
ferdbold added a comment to T126421: RESTBase fails to start up on MW-Vagrant.

Looks like this issue is back :/ I'm getting 503's again in console as well as this warning in Chrome when trying to open up VisualEditor:

Feb 18 2016, 6:43 PM · Services, Patch-For-Review, RESTBase, MediaWiki-Vagrant

Feb 11 2016

ferdbold added a comment to T126421: RESTBase fails to start up on MW-Vagrant.

I can confirm it works. Thanks a lot!

Feb 11 2016, 5:42 AM · Services, Patch-For-Review, RESTBase, MediaWiki-Vagrant

Feb 10 2016

ferdbold added a comment to T126421: RESTBase fails to start up on MW-Vagrant.

Hmm still no go for me. I can't make out anything out of my logs, maybe you could take a look:

Feb 10 2016, 5:12 PM · Services, Patch-For-Review, RESTBase, MediaWiki-Vagrant
ferdbold added a comment to T126421: RESTBase fails to start up on MW-Vagrant.

I am not getting a prompt to choose either VE or wikitext... I only have an "Edit Source" button which takes me to the wikitext editor.

Feb 10 2016, 6:47 AM · Services, Patch-For-Review, RESTBase, MediaWiki-Vagrant
ferdbold created T126421: RESTBase fails to start up on MW-Vagrant.
Feb 10 2016, 6:01 AM · Services, Patch-For-Review, RESTBase, MediaWiki-Vagrant

Feb 4 2016

ferdbold created T125765: git-update and provisioning takes a really long time to complete.
Feb 4 2016, 9:17 AM · Wikimedia-Hackathon-2016, MediaWiki-Vagrant
ferdbold updated the task description for T125767: [Regression wmf.12] FocusableNode invisibles produces weird results with graph, templates and transclusions.
Feb 4 2016, 7:50 AM · MW-1.27-release (WMF-deploy-2016-02-09_(1.27.0-wmf.13)), MW-1.27-release (WMF-deploy-2016-02-02_(1.27.0-wmf.12)), VisualEditor-ContentEditable, Patch-For-Review, VisualEditor
ferdbold renamed T125767: [Regression wmf.12] FocusableNode invisibles produces weird results with graph, templates and transclusions from FocusableNode invisibles produces weird results with graphs to FocusableNode invisibles produces weird results with graph, templates and transclusions.
Feb 4 2016, 7:48 AM · MW-1.27-release (WMF-deploy-2016-02-09_(1.27.0-wmf.13)), MW-1.27-release (WMF-deploy-2016-02-02_(1.27.0-wmf.12)), VisualEditor-ContentEditable, Patch-For-Review, VisualEditor
ferdbold created T125767: [Regression wmf.12] FocusableNode invisibles produces weird results with graph, templates and transclusions.
Feb 4 2016, 7:48 AM · MW-1.27-release (WMF-deploy-2016-02-09_(1.27.0-wmf.13)), MW-1.27-release (WMF-deploy-2016-02-02_(1.27.0-wmf.12)), VisualEditor-ContentEditable, Patch-For-Review, VisualEditor

Jan 2 2016

ferdbold moved T122750: Add Vega 2 support to VE from Backlog to VisualEditor on the Graphs board.
Jan 2 2016, 9:29 PM · MW-1.27-release (WMF-deploy-2016-03-01_(1.27.0-wmf.15)), VisualEditor, Graphs
ferdbold created T122750: Add Vega 2 support to VE.
Jan 2 2016, 9:28 PM · MW-1.27-release (WMF-deploy-2016-03-01_(1.27.0-wmf.15)), VisualEditor, Graphs
ferdbold added a comment to T118895: "Script file not found: worker-json.js" appears after opening the Graph editor dialog.

Closing this as it doesn't happen anymore in local as well as on mediawiki.org

Jan 2 2016, 8:21 PM · CodeEditor, Graphs, Graph-VisualEditor, VisualEditor
ferdbold closed T118895: "Script file not found: worker-json.js" appears after opening the Graph editor dialog as Resolved.
Jan 2 2016, 8:19 PM · CodeEditor, Graphs, Graph-VisualEditor, VisualEditor
ferdbold closed T118895: "Script file not found: worker-json.js" appears after opening the Graph editor dialog, a subtask of T119233: [Objective] It's easier to create and edit charts from within VisualEditor, as Resolved.
Jan 2 2016, 8:19 PM · User-Ryasmeen, Category, Epic, Graphs, VisualEditor
ferdbold closed T121638: VE GraphNode tests are failing as Resolved.
Jan 2 2016, 8:14 PM · MW-1.27-release (WMF-deploy-2016-01-12_(1.27.0-wmf.10)), Graphs, VisualEditor

Dec 23 2015

ferdbold moved T121638: VE GraphNode tests are failing from Backlog to VisualEditor on the Graphs board.
Dec 23 2015, 9:39 PM · MW-1.27-release (WMF-deploy-2016-01-12_(1.27.0-wmf.10)), Graphs, VisualEditor

Dec 17 2015

ferdbold added a comment to T121638: VE GraphNode tests are failing.

How is this possible? Doesn't jenkins run the tests before trying to merge?

Dec 17 2015, 5:57 PM · MW-1.27-release (WMF-deploy-2016-01-12_(1.27.0-wmf.10)), Graphs, VisualEditor

Dec 9 2015

ferdbold moved T120699: [Regression wmf.8] Saving a page after adding any focusable node throws error "TypeError: rect is undefined" from Backlog to VisualEditor on the Graphs board.
Dec 9 2015, 8:59 PM · MW-1.27-release (WMF-deploy-2016-01-12_(1.27.0-wmf.10)), VisualEditor-ContentEditable, VisualEditor

Dec 7 2015

ferdbold created T120630: Refactor TableWidget to use a proper model.
Dec 7 2015, 4:26 AM · MW-1.29-release (WMF-deploy-2016-11-08_(1.29.0-wmf.2)), Technical-Debt, VisualEditor, Graphs

Dec 4 2015

ferdbold added a comment to T120319: Migrate graphs from Vega 1 to Vega 2 syntax on edit with VE.

@Krenair I was talking about a graph edit specifically. If the user opens the graph dialog of a graph made with Vega 1, the tool should automagically convert it to Vega 2.

Dec 4 2015, 3:08 AM · VisualEditor, Graphs

Dec 3 2015

ferdbold created T120319: Migrate graphs from Vega 1 to Vega 2 syntax on edit with VE.
Dec 3 2015, 11:28 PM · VisualEditor, Graphs
ferdbold moved T119261: While using the resize handler on a graph, the lowest limit for resizing is 60x60px, but not when resizing from dialog from Backlog to VisualEditor on the Graphs board.
Dec 3 2015, 5:04 AM · MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Graphs, Graph-VisualEditor, VisualEditor
ferdbold added a project to T119261: While using the resize handler on a graph, the lowest limit for resizing is 60x60px, but not when resizing from dialog: Graphs.
Dec 3 2015, 5:04 AM · MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Graphs, Graph-VisualEditor, VisualEditor
ferdbold moved T119902: [Regression pre-wmf.8] Graph editor crashes upon opening, error in the console "ReferenceError: vg is not defined" from Backlog to VisualEditor on the Graphs board.
Dec 3 2015, 5:04 AM · MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Graphs, Graph-VisualEditor, VisualEditor
ferdbold added a project to T119902: [Regression pre-wmf.8] Graph editor crashes upon opening, error in the console "ReferenceError: vg is not defined": Graphs.
Dec 3 2015, 5:04 AM · MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Graphs, Graph-VisualEditor, VisualEditor
ferdbold moved T120145: [Regression pre-wmf.8] Old graphs not rendered client-side anymore from Backlog to VisualEditor on the Graphs board.
Dec 3 2015, 5:03 AM · Regression, Patch-For-Review, Graphs

Dec 2 2015

ferdbold archived Graph-VisualEditor.
Dec 2 2015, 11:26 PM
ferdbold edited Description on Graph-VisualEditor.
Dec 2 2015, 11:25 PM
ferdbold created T120145: [Regression pre-wmf.8] Old graphs not rendered client-side anymore.
Dec 2 2015, 11:17 PM · Regression, Patch-For-Review, Graphs
ferdbold added a comment to T119902: [Regression pre-wmf.8] Graph editor crashes upon opening, error in the console "ReferenceError: vg is not defined".

This is weird, I'm able to reproduce this. Graphs in read mode aren't being rendered, though if I go save some edit through wikitext editor, everything works well again. This is surely related to the new vega2 support ext.graph is doing

Dec 2 2015, 9:28 PM · MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Graphs, Graph-VisualEditor, VisualEditor

Nov 26 2015

ferdbold updated subscribers of T106362: Create API module to let Graphoid get graph spec JSON blob.
Nov 26 2015, 5:29 PM · MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Patch-For-Review, Graphs
ferdbold awarded T106362: Create API module to let Graphoid get graph spec JSON blob a Like token.
Nov 26 2015, 5:28 PM · MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Patch-For-Review, Graphs

Nov 21 2015

ferdbold added a comment to T119263: When resizing a graph, an index over an axis overlaps with each other when its reduced below 85x85 px.

The current 60x60 limit was completely arbitrary, it's trivial to fix and probably a good idea ;)

Nov 21 2015, 12:24 AM · Graph-VisualEditor, VisualEditor
ferdbold updated subscribers of T119261: While using the resize handler on a graph, the lowest limit for resizing is 60x60px, but not when resizing from dialog.

Yeah me and @Esanders noticed that as well, that's because OO.ui.DimensionsWidget doesn't account for resizable nodes when it probably should.

Nov 21 2015, 12:23 AM · MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Graphs, Graph-VisualEditor, VisualEditor

Nov 20 2015

ferdbold added a comment to T119129: Graphoid installation fails.

If so, we should probably update the Graphoid documentation to reflect that

Nov 20 2015, 8:21 AM · Graphoid

Nov 19 2015

ferdbold created T119129: Graphoid installation fails.
Nov 19 2015, 10:19 PM · Graphoid
ferdbold updated subscribers of T119050: Parametric JSON builder.
Nov 19 2015, 5:58 PM · RfC, MediaWiki-Templates, ArchCom-RfC
ferdbold added a comment to T118896: Graph does not appear in Read mode after saving the page.

Update: This is due to a clash between assumptions that both VE and the Graph extension makes on what the page data is. On a save from VE, the HTML presented to the user is not actually rerendered from the server, but rather served by VE through Parsoid.

Nov 19 2015, 3:38 AM · Verified-in-Phase2, Verified-in-Phase0, Verified, MW-1.29-release (WMF-deploy-2016-11-29_(1.29.0-wmf.4)), Graphs, Graph-VisualEditor, VisualEditor
ferdbold moved T119017: Bottom paddings visual issue from Backlog to For review on the Graph-VisualEditor board.
Nov 19 2015, 3:31 AM · Graphs, OOjs-UI, VisualEditor, Graph-VisualEditor
ferdbold moved T109631: Edit graph size in VisualEditor from For review to Merged on the Graph-VisualEditor board.
Nov 19 2015, 2:42 AM · User-notice, Verified, Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), VisualEditor, Graph-VisualEditor
ferdbold created T119017: Bottom paddings visual issue.
Nov 19 2015, 12:10 AM · Graphs, OOjs-UI, VisualEditor, Graph-VisualEditor
ferdbold moved T109631: Edit graph size in VisualEditor from In Progress to For review on the Graph-VisualEditor board.
Nov 19 2015, 12:04 AM · User-notice, Verified, Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), VisualEditor, Graph-VisualEditor

Nov 17 2015

ferdbold added a comment to T118895: "Script file not found: worker-json.js" appears after opening the Graph editor dialog.

This file is part of Ace Editor and not MW, so in theory this should happen anywhere ve.ui.MWAceEditorWidget is being used

Nov 17 2015, 11:32 PM · CodeEditor, Graphs, Graph-VisualEditor, VisualEditor
ferdbold moved T118898: "TypeError: can't convert undefined to object" apperas when I delete all the co-ordinates from Data section of the Graph editor and cannot open any other inspector after that from Backlog to For review on the Graph-VisualEditor board.
Nov 17 2015, 11:18 PM · MW-1.27-release (WMF-deploy-2016-02-02_(1.27.0-wmf.12)), Graphs, Graph-VisualEditor, VisualEditor
ferdbold closed T118813: Only load vega.js upon opening graph edit dialog as Resolved.
Nov 17 2015, 8:08 PM · Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Patch-For-Review, Performance, VisualEditor, Graph-VisualEditor
ferdbold moved T118813: Only load vega.js upon opening graph edit dialog from For review to Merged on the Graph-VisualEditor board.
Nov 17 2015, 8:08 PM · Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Patch-For-Review, Performance, VisualEditor, Graph-VisualEditor
ferdbold added a comment to T118896: Graph does not appear in Read mode after saving the page.

Is this happening with bar graphs? We pushed a fix this morning that fixes this kind of issue
T109645: Bar charts are not displaying properly directly after a save in VisualEditor

Nov 17 2015, 8:07 PM · Verified-in-Phase2, Verified-in-Phase0, Verified, MW-1.29-release (WMF-deploy-2016-11-29_(1.29.0-wmf.4)), Graphs, Graph-VisualEditor, VisualEditor
ferdbold triaged T118898: "TypeError: can't convert undefined to object" apperas when I delete all the co-ordinates from Data section of the Graph editor and cannot open any other inspector after that as High priority.
Nov 17 2015, 8:05 PM · MW-1.27-release (WMF-deploy-2016-02-02_(1.27.0-wmf.12)), Graphs, Graph-VisualEditor, VisualEditor
ferdbold raised the priority of T118895: "Script file not found: worker-json.js" appears after opening the Graph editor dialog from High to Needs Triage.
Nov 17 2015, 8:05 PM · CodeEditor, Graphs, Graph-VisualEditor, VisualEditor
ferdbold triaged T118895: "Script file not found: worker-json.js" appears after opening the Graph editor dialog as High priority.
Nov 17 2015, 8:05 PM · CodeEditor, Graphs, Graph-VisualEditor, VisualEditor
ferdbold moved T118813: Only load vega.js upon opening graph edit dialog from In Progress to For review on the Graph-VisualEditor board.
Nov 17 2015, 7:32 PM · Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Patch-For-Review, Performance, VisualEditor, Graph-VisualEditor
ferdbold claimed T109631: Edit graph size in VisualEditor.
Nov 17 2015, 6:57 PM · User-notice, Verified, Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), VisualEditor, Graph-VisualEditor
ferdbold claimed T118813: Only load vega.js upon opening graph edit dialog.
Nov 17 2015, 6:57 PM · Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Patch-For-Review, Performance, VisualEditor, Graph-VisualEditor
ferdbold moved T109645: Bar charts are not displaying properly directly after a save in VisualEditor from For review to Merged on the Graph-VisualEditor board.
Nov 17 2015, 6:57 PM · Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), VisualEditor, Graph-VisualEditor
ferdbold triaged T118883: Boolean values in graph specs not behaving properly after a save in VE as Normal priority.
Nov 17 2015, 6:39 PM · Graph-VisualEditor, Graphs
ferdbold added a project to T118883: Boolean values in graph specs not behaving properly after a save in VE: Graph-VisualEditor.
Nov 17 2015, 6:38 PM · Graph-VisualEditor, Graphs
ferdbold moved T116548: Clean up redundant graph-ve i18n messages from For review to Merged on the Graph-VisualEditor board.
Nov 17 2015, 6:38 PM · MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Patch-For-Review, Graphs, Graph-VisualEditor
ferdbold closed T116548: Clean up redundant graph-ve i18n messages as Resolved.
Nov 17 2015, 6:38 PM · MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Patch-For-Review, Graphs, Graph-VisualEditor
ferdbold created T118883: Boolean values in graph specs not behaving properly after a save in VE.
Nov 17 2015, 6:35 PM · Graph-VisualEditor, Graphs
ferdbold added a comment to T106101: Upgrade Vega to version 2.0.

Okay good, keep us posted :)

Nov 17 2015, 6:32 PM · Graphs
ferdbold moved T118813: Only load vega.js upon opening graph edit dialog from Backlog to In Progress on the Graph-VisualEditor board.
Nov 17 2015, 6:31 PM · Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Patch-For-Review, Performance, VisualEditor, Graph-VisualEditor
ferdbold renamed T118813: Only load vega.js upon opening graph edit dialog from Only load vega.js upon opening graph editing dialog to Only load vega.js upon opening graph edit dialog.
Nov 17 2015, 1:55 AM · Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Patch-For-Review, Performance, VisualEditor, Graph-VisualEditor
ferdbold created T118813: Only load vega.js upon opening graph edit dialog.
Nov 17 2015, 1:55 AM · Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Patch-For-Review, Performance, VisualEditor, Graph-VisualEditor
ferdbold moved T109631: Edit graph size in VisualEditor from Backlog to In Progress on the Graph-VisualEditor board.
Nov 17 2015, 1:37 AM · User-notice, Verified, Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), VisualEditor, Graph-VisualEditor
ferdbold moved T109645: Bar charts are not displaying properly directly after a save in VisualEditor from In Progress to For review on the Graph-VisualEditor board.
Nov 17 2015, 1:23 AM · Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), VisualEditor, Graph-VisualEditor
ferdbold updated subscribers of T109645: Bar charts are not displaying properly directly after a save in VisualEditor.

Figured out what was causing this: Once you apply changes to a page, any boolean values in a spec set to true will show up as either "" or null in mw.config.wgGraphSpecs, causing the graph to not render properly (bar graphs have a band property set to true, which is why they fail but not area and line graphs). Once you refresh the page though, booleans are fine.

Nov 17 2015, 1:16 AM · Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), VisualEditor, Graph-VisualEditor
ferdbold claimed T109645: Bar charts are not displaying properly directly after a save in VisualEditor.
Nov 17 2015, 12:49 AM · Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), VisualEditor, Graph-VisualEditor
ferdbold moved T109645: Bar charts are not displaying properly directly after a save in VisualEditor from Backlog to In Progress on the Graph-VisualEditor board.
Nov 17 2015, 12:47 AM · Graphs, MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), VisualEditor, Graph-VisualEditor
ferdbold moved T116548: Clean up redundant graph-ve i18n messages from In Progress to For review on the Graph-VisualEditor board.
Nov 17 2015, 12:45 AM · MW-1.27-release (WMF-deploy-2015-12-08_(1.27.0-wmf.8)), Patch-For-Review, Graphs, Graph-VisualEditor
ferdbold added a comment to T115767: [Regression?] A <graph> on a particular page can't be edited .

I checked it again today and that graph works now. Maybe it indeed was an issue in Parsoid and *something* solved this issue?

Nov 17 2015, 12:43 AM · Graphs, Graph-VisualEditor, VisualEditor
ferdbold moved T116854: Styling regressions in table widget from For review to Merged on the Graph-VisualEditor board.
Nov 17 2015, 12:34 AM · Graphs, MW-1.27-release (WMF-deploy-2015-11-03_(1.27.0-wmf.5)), Graph-VisualEditor, VisualEditor