HomePhabricator

(stable) Fix additional Mercurial/Python compatibility issues in "arc land"

Description

(stable) Fix additional Mercurial/Python compatibility issues in "arc land"

Summary:
Ref PHI1805. Under some combination of versions (Python 3.8?), "arc-ls-markers" is running into additional Python runtime issues.

Sprinkle more "b" around to resolve them? Also clean up a couple of plain "arc" issues.

Test Plan:
Landed a change in Mercurial.

Some of this works fine without changes in Python 3.7/2.7 against Mercurial 4.7/5.4, so this may not be exhaustive.

Differential Revision: https://secure.phabricator.com/D21393

Details

Provenance
epriestleyAuthored on Jul 7 2020, 5:12 PM
Parents
rARC1a54e1103c23: (stable) Allow "hg arc-ls-markers" to run under Python 2 or Python 3
Branches
Unknown
Tags
Unknown
ChangeId
None