HomePhabricator

Drop some backwards-compatibility code

Authored by Anomie on May 11 2016, 3:57 PM.

Description

Drop some backwards-compatibility code

CentralAuth's policy is that master is compatible with core master only,
so let's drop some code that only exists to support old versions:

  • Pre-SessionManager compatibility code, including the 'centralauth-autoaccount' user right.
  • Pre-CentralIdLookup compatibility code.
  • OAuth hooks that were needed before CentralIdLookup.
  • GlobalUserPage hook that was needed before CentralIdLookup.
  • Functions deprecated when the API help i18n was added.
  • Stuff deprecated when the API token handling was redone.

Change-Id: I5c87817fdf918f79943c58e643c7dbf3f4b83b87