CodeReview: Modified the method we use to output the revision ID. If more than one repository is defined then CodeReview makes a lousy job of distinguishing between them, e.g. in page titles, e-mails, etc. This update makes it clearer by including the repository name in situations where this would be useful, e.g. instead of just "r192" we now use "mediawiki.r192" (where appropriate). Note that if only one repository is set up then the old method is used, as there is no source of confusion. The new method is only used when (a) there are multiple repositories defined and (b) the particular situation would benefit from this extra information.
There are two new functions in the CodeRepository class to facilitate this:
- getRevIdString() - returns the revision as a string, e.g. "r192".
- getRevIdStringUnique() - returns a system-unique string referring to the revision. If there is only one repository set up then it returns the same as getRevIdString(), but if there are multiple repositories it will include the repository name in the string, e.g. "mediawiki.r192".
The CodeRevision class has a similar pair of functions, which act as wrappers for the above so they can be easily accessed from a Revision object. They are getIdString() and getIdStringUnique().
All messages (in all languages) which include a revision number have been updated to remove the "r" which was hard-coded into the message. I made a new message string for this ('code-rev-id') but perhaps this is overkill. If this is unlikely to be localised then we could hard-code it into getRevIdString() instead.