HomePhabricator

build: Updating dependencies

Description

build: Updating dependencies

composer:

  • mediawiki/mediawiki-codesniffer: 31.0.0 → 37.0.0
  • mediawiki/minus-x: 0.3.2 → 1.1.1
  • php-parallel-lint/php-parallel-lint: 1.0.0 → 1.3.0

npm:

  • eslint-config-wikimedia: 0.14.1 → 0.20.0
  • grunt: 1.0.4 → 1.4.0
  • grunt-banana-checker: 0.8.1 → 0.9.0
  • grunt-eslint: 22.0.0 → 23.0.0
  • grunt-stylelint: 0.11.1 → 0.16.0
  • stylelint-config-wikimedia: 0.6.0 → 0.10.3

Additional changes:

  • And updating CoC link to use Special:MyLanguage (T202047).
  • Also added phpcbf to "composer fix" command.
  • Set private: true in package.json.
  • Use json file extension for the stylelint config file.
  • Set root: true in ESLint config (T206485).
  • eslint: Renamed wikimedia/client profile to client-es5 (T277085).
  • eslint: Added wikimedia/mediawiki profile (T262222).
  • eslint: Removed globals mw, OO, included via wikimedia/mediawiki profile (T262222).
  • eslint: Dropped the empty global definition.
  • Enable eslint caching.
  • Removing manual reportUnusedDisableDirectives for eslint.

Change-Id: Id324d87aea4373dd055986cc1077f6fcba3d323c

Details

Provenance
LibUp-botAuthored on Jul 22 2021, 7:31 AM
Parents
rEDSCb738c7d0e0c4: First draft
Branches
Unknown
Tags
Unknown
References
refs/changes/73/706573/1
ChangeId
Id324d87aea4373dd055986cc1077f6fcba3d323c