Simplify loadCallback code flow
- loadEL: There were a few cases where this was conditionally assigned based on other prior decisions. This felt a bit fragile. To avoid breaking this in the future and to make to easier to understand each individual statement, refactor it so that it can be assigned in an idiomatic 'ensure set' way. Meaning, "set x if x is not already set". With other circumstances ensuring we only reach it if need be (with an outer conditional, and/or early return). Previously this was inferred by carefully repeating certain conditions where needed.
- reinit (test code): Update to account for oversampling. Wasn't actually broken in current tests, but by using !loadEL, naturaly works.
- Remove Object.keys() check before for-loop. The main code below it already accounts for it being empty by producing an empty array, which make the check redundant. Also, in JS computing Object.keys() relatively expensive (more than for-loop itself). Super tiny either way though, but given it effectively means we iterate the whole object to decide whether to start iterating it (again), removed and simplifies the code :)
- Update getGeo/getUA oversampling checks to not create two arrays where one isn't used. Instead, return the one created earlier, or, allocate the main one later. I opted for the former.