HomePhabricator

build: Updating dependencies

Description

build: Updating dependencies

composer:

  • wikibase/wikibase-codesniffer: ^0.4.1 → 0.5.1 The following sniffs are failing and were disabled:
    • MediaWiki.Commenting.LicenseComment.InvalidLicenseTag

npm:

Additional changes:

  • Replaced "jakub-onderka" packages with "php-parallel-lint".
  • Committed package-lock.json (T179229) too.
  • And updating CoC link to use Special:MyLanguage (T202047).
  • Also sorted "composer fix" command to run phpcbf last.
  • Set private: true in package.json.
  • Set root: true in .eslintrc.json (T206485).
  • Enable eslint caching.

Change-Id: I0457c4179054cacd8af4879278d0c5bb1db052da

Details

Provenance
LibUp-botAuthored on Jan 18 2021, 10:43 PM
Parents
rEPS1710c767f24c: Update Wikibase CodeSniffer to version 0.4.1
Branches
Unknown
Tags
Unknown
ChangeId
I0457c4179054cacd8af4879278d0c5bb1db052da