HomePhabricator

build: Updating dependencies

Description

build: Updating dependencies

composer:

  • mediawiki/mediawiki-codesniffer: 34.0.0 → 35.0.0 The following sniffs are failing and were disabled:
    • MediaWiki.Commenting.FunctionComment.WrongStyle
  • mediawiki/minus-x: 1.1.0 → 1.1.1

npm:

  • eslint-config-wikimedia: 0.17.0 → 0.18.1

Additional changes:

  • Added the "composer phan" command to conveniently run phan.

Change-Id: I3df6f36557157493ce9f79f0fef71761ca7668e4

Details

Provenance
LibUp-botAuthored on Jan 30 2021, 2:29 AM
Parents
rERLS8d744975cc8a: Merge "Improve function and property documentation"
Branches
Unknown
Tags
Unknown
References
wmf/1.36.0-wmf.29
ChangeId
I3df6f36557157493ce9f79f0fef71761ca7668e4