HomePhabricator

Rename "parent", SecurePoll_BasePage, SecurePoll_Page to be more descriptive

Authored by Fhocutt.

Description

Rename "parent", SecurePoll_BasePage, SecurePoll_Page to be more descriptive

  • Rename SecurePoll_BasePage to SecurePoll_SpecialSecurePoll
  • Rename SecurePoll_Page to SecurePoll_ActionPage to further distinguish it from SecurePoll_SpecialSecurePoll, the associated SpecialPage
  • Rename SecurePoll_Page::parent to SecurePoll_ActionPage::specialPage to reduce confusion with the reserved word parent

Change-Id: I17641f9c5bcf027ddace79fe0fd64fa1ceaf50e7