HomePhabricator

build: Updating dependencies

Description

build: Updating dependencies

composer:

  • mediawiki/mediawiki-codesniffer: 28.0.0 → 29.0.0

npm:

  • grunt-stylelint: 0.8.0 → 0.13.0
  • stylelint-config-wikimedia: 0.4.1 → 0.8.0 The following rules are failing and were disabled:
    • font-family-no-missing-generic-family-keyword
    • function-blacklist

Additional changes:

  • Remove direct "stylelint" dependency in favor of "grunt-stylelint".
  • Also sorted "composer fix" command to run phpcbf last.

Change-Id: I476c2137968b61ee00c360377c9c9dd1f23bf001

Details

Committed
UmherirrenderJan 26 2020, 6:14 PM
Parents
rEWIS52931bc131f4: build: Updating npm dependencies
Branches
Unknown
Tags
Unknown
ChangeId
I476c2137968b61ee00c360377c9c9dd1f23bf001