HomePhabricator

Make separate functions for better code readability

Authored by SPQRobin.

Description

Make separate functions for better code readability

Call analyzePrefix with a title objects which checks namespaces.
Make a separate function for the second part of onShowMissingArticle. So the biggest part of the commit is just decreasing the indenting.
In general, instead of "if( no info page ) { do 1; return; } do 2;" it is now "if( info page ) { call other function for 2; return; } do 1"

Change-Id: I8367f99a8e23eda4034d6e1b51afc477cb284f92

Details

Committed
SPQRobinJul 26 2012, 7:20 PM
Parents
rEWMIe50743517189: Merge "Add more to info page of incubating wikis"
Branches
Unknown
Tags
Unknown
ChangeId
I8367f99a8e23eda4034d6e1b51afc477cb284f92