HomePhabricator
Diffusion Scap b7dbba3881e5

Changes for require_valid_service

Authored by thcipriani on Aug 28 2017, 11:07 PM.

Description

Changes for require_valid_service

Summary:
Testing out some of these commands on the jobrunner boxes it seems like
the systemctl in use there (systemd 215) is too old to accept the
--value flag. This throws an error.

I also realized that requesting a service that doesn't exist DOES NOT
exit non-zero, but just shows LoadState=not-found.

Reviewers: demon, mmodell, dduvall, Release-Engineering-Team

Reviewed By: demon, Release-Engineering-Team

Tags: Release-Engineering-Team

Differential Revision: https://phabricator.wikimedia.org/D760

Details

Committed
thciprianiAug 29 2017, 3:52 PM
Reviewer
Release-Engineering-Team
Differential Revision
D760: Changes for require_valid_service
Parents
rMSCA71b9ad6fbf69: Adding code of conduct file
Branches
Unknown
Tags
Unknown
ChangeId
None
Build Status
Buildable 2156
Build 3501: ci-jessieJenkins