HomePhabricator

Third argument to unpack() requires PHP 7.1

Description

Third argument to unpack() requires PHP 7.1

On PHP 7.0, it looks like this code would have raised a warning and
given random results, because it would interpret the first byte of $tail
as the comment length instead of the correct one. Thanks for being
permissive about unrecognized function parameters, PHP!

(The actual reason I found and fixed this is because the phan annotation
here was giving me an error on PHP 7.3: "UnusedPluginSuppression Plugin
BuiltinSuppressionPlugin suppresses issue PhanParamTooManyInternal on
this line but this suppression is unused or suppressed elsewhere".)

Change-Id: I910f78698d1a53e8a90ddf243a4d65be87f29ca9

Details

Provenance
SimetricalAuthored on Apr 10 2019, 11:08 AM
Parents
rMW79e1a48365d3: Localisation updates from https://translatewiki.net.
Branches
Unknown
Tags
Unknown
ChangeId
I910f78698d1a53e8a90ddf243a4d65be87f29ca9