HomePhabricator

Allow PHP version check to execute on older versions of PHP

Description

Allow PHP version check to execute on older versions of PHP

A change to update.php used the null coalesce (??) operator.
While this is normally fine, the code in question executes
before the PHP version check, and causes an unfriendly PHP
error rather than the intended helpful error. Use the older-style
isset() call instead, so that the PHP version check will get
a chance to execute.

Bug: T213893
Change-Id: I22e4a24bed9e0b29e08afc7b9468e7bfd81d7d57

Details

Provenance
BPirkleAuthored on Jul 11 2019, 2:16 AM
Parents
rMW50a72860b6ea: Merge "objectcache: remove inheritence from CachedBagOStuff"
Branches
Unknown
Tags
Unknown
ChangeId
I22e4a24bed9e0b29e08afc7b9468e7bfd81d7d57

Event Timeline