HomePhabricator

Minimal PSR-3 compatible logger layer

Authored by bd808.

Description

Minimal PSR-3 compatible logger layer

Provide a minimal PSR-3 compatible logger layer to make backporting
critical updates from 1.25+ easier. It also serves to allow extensions
that maintain backwards compatibility with the 1.23 LTS releases to
migrate to the new logging system.

A copy of the official PSR-3 implementation is added in
includes/libs/psr3 with the omission of PHP5.4+ Traits. In MediaWiki
1.25+ this library will be provided via Composer.

Bug: T91653
Change-Id: If385e722c62dc1f989af6fdee404535bad989acc

Details

Committed
LegoktmApr 15 2015, 4:48 AM
Parents
rMW39bf3bda1aed: Make AutoLoaderTest handle namespaces
Branches
Unknown
Tags
Unknown
ChangeId
If385e722c62dc1f989af6fdee404535bad989acc