HomePhabricator

gerrit: make Apache config compatible with 2.4

Description

gerrit: make Apache config compatible with 2.4

Making the Gerrit Apache config compatible with 2.2 and 2.4
Apache versions.

It may also work without this but only if/because mod_access_compat is
loaded.

https://httpd.apache.org/docs/trunk/mod/mod_access_compat.html

This module is loaded now by default but will be removed in the next
distro version. So this change makes it future-proof and it does not
rely on the special module and it will be untouched on the old server.

The "env not bad_browser" part is just like we ended up doing it for
lists.wikimedia.org. You can compare there.

Bug:T70271
Change-Id: I8e30cfda0bd2e8d857f066d73fae6b87b4fb4eec

Details

Provenance
DzahnAuthored on Jul 8 2016, 7:38 PM
PaladoxCommitted on Jul 11 2016, 10:01 PM
Parents
rOPUP5d8ed65a4641: Revert "TEMPORARY HACK: Add access_new_install to iron"
Branches
Unknown
Tags
Unknown
ChangeId
I8e30cfda0bd2e8d857f066d73fae6b87b4fb4eec