HomePhabricator

Tools: Do not require redundant package python-celery-with-redis

Description

Tools: Do not require redundant package python-celery-with-redis

python-celery-with-redis is a "bundle" that "installs the following
packages: ['celery>=3.0,<4.0', 'redis>=2.4.4']". However, if those
specific versions were indeed wanted, they wouldn't actually be
fulfilled by the package as it just requires python-celery and
python-redis unconditionally.

As Debian is very careful to stay backwards-compatible and we already
require the packages python-celery and python-redis (via
::redis::client::python) in
modules/toollabs/manifests/exec_environ.pp, this change removes the
redundant requirement.

Bug: T91874
Change-Id: I53a9dfe025717523cbf3f46f2bc9070df62049d0