HomePhabricator

Update configuration for logstash 1.5.3

Description

Update configuration for logstash 1.5.3

  • Remove obsolete logstash-contrib package
  • Setup trebuchet package for distributing logstash plugins
  • Use require_package() to clean up dependencies
  • Switch from deprecated elasticsearch_http to elasticsearch output
  • Change logstash::output::elasticsearch from class to define
  • Reuse logstash::output::elasticsearch for apifeatureusage output

Bug: T99735
Change-Id: I24c049139f7ff4b70a4504eea4e4d49d40e79827

Details

Provenance
bd808Authored on
fgiunchediCommitted on Aug 11 2015, 3:38 PM
Parents
rOPUP36e14a2207a3: new_wmf_service: fix bug with wrong function name
Branches
Unknown
Tags
Unknown
ChangeId
I24c049139f7ff4b70a4504eea4e4d49d40e79827