HomePhabricator

Add support for elasticsearch 2

Authored by Paladox on Sep 29 2016, 7:23 PM.

Description

Add support for elasticsearch 2

Maniphest Tasks: T146843

Summary:
Adds a new config that is used to tell which version elasticsearch you
use, for example if you use elasticsearch 1, then you put in there 1, and
if you use 2, then 2.

@EBernhardson helped alot with figuring how to get it to work with
elasticsearch 2 properly.

@mmodell helped with helpig me creat a config we could use.

Fixes T146843

Change-Id: Id275378a7d2827d2dca6c1b3c99d60aa767ee059

Reviewers: mmodell

Reviewed By: mmodell

Subscribers: Aklapper, mmodell, EBernhardson

Differential Revision: https://phabricator.wikimedia.org/D388

Details

Committed
mmodellSep 29 2016, 7:32 PM
Reviewer
mmodell
Parents
rPHAB16a2b7e2eabb: Merge branch 'upstream/stable' into wmf/stable
Branches
Unknown
Tags
Unknown
ChangeId
Id275378a7d2827d2dca6c1b3c99d60aa767ee059