Make function names more consistent, use more flexible getPortlet, make…

Authored by Isarra on May 19 2017, 8:58 AM.

Description

Make function names more consistent, use more flexible getPortlet, make functions protected as opposed to private (for extensibility/compatibility with 1.29), add comments explaining what the crap some of these things even are/what developers should be doing with them

This got a bit out of hand, as per usual when I abandon a change partway
through for several weeks and then come back to it.

Change-Id: Ib28614cce03ffd855e9499e9ea2dea0dcd8597d4

Details