Having a property with the name `$` is confusing because it does not well describe what the method does.
The name was probably chosen because it behaves like one of the many overloaded features of `window.$`/`jquery`, specifically you can pass in a selector and get a collection, e.g. `this.$( '.class' )`. However it is not clear that `this.$( '<span>' )` and `this.$( fn )` will not work.
An added complication is that OOUI used to define a property `$` which //was// the full jQuery global, but bound to the local iFrame's window. We deprecated this method a while ago when we dropped our iFrame approach for dialogs, but the property still exists as an alias to `window.$`
As the definition of the function is just a mapping to `this.$el.find`, so I would suggest renaming to `this.find` or `this.findInEl`, or simply not replace it at all: `this.$el.find` is not that long, and makes it completely clear what is happening.
We also now have a linting rule that prevents users from using global selectors at all ( `$( '.selector' )` ), which I imagine another reason why this method was implemented.
edit: Bonus reason to do this is 'this.$' messes with eslint-plugin-jquery, which doesn't recognise it as returning a jQuery collection.