Page MenuHomePhabricator

usersearch on Tool-Labs lists invalid URLs for Contributions by User to a page
Closed, DuplicatePublic

Description

When I go to a page history, click on Contributions by User, type my name, and get the list, clicking on the diff takes me to a page with http://www.homeimprovement.com prefixed to it.
For eg:
https://tools.wmflabs.org/usersearch/usersearch.py?name=Rsrikanth05&page=Mumbai&max=250&server=enwiki
http://https//en.wikipedia.org/w/index.php?title=Mumbai&diff=prev&oldid=670092564 goes to http://www.homeimprovement.com/en.wikipedia.org/w/?title=Mumbai&diff=prev&oldid=670092564
This happens with Firefox.

The issue is because the urls on the page point to https and not https:
A missing : is resulting in this error.

Event Timeline

Rsrikanth05 raised the priority of this task from to Unbreak Now!.
Rsrikanth05 updated the task description. (Show Details)
Rsrikanth05 added a subscriber: Rsrikanth05.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 5 2015, 8:17 PM
Krenair added a subscriber: Krenair.
Aklapper lowered the priority of this task from Unbreak Now! to Needs Triage.Jul 6 2015, 8:54 AM

Confirming, however the bottom of that page says

Bugs, suggestions, questions? Contact the author at User talk:Scottywong

@Rsrikanth05: Did you do that? Not sure if anyone will see this Phabricator task...

I'm also reverting the priority of this task - there is a trivial workaround (edit the URL bar) and no reason to set "Unbreak now" here.

Aklapper renamed this task from Https bug with Contributions by User to a page to usersearch on Tool-Labs lists invalid URLs for Contributions by User to a page.Jul 6 2015, 8:56 AM
Aklapper set Security to None.

@Aklapper Scottywong has retired on the English Wikipedia, hence I posted it here. Forgive me for the priority levels. This is the first time I'm using Phabricator.

Sitic closed this task as a duplicate of T106040: Edits by user results.Jul 18 2015, 6:53 PM