Page MenuHomePhabricator

Numerical sorting
Closed, ResolvedPublic

Description

This card tracks a proposal that's currently part of the Community Wishlist Survey: https://meta.wikimedia.org/wiki/2015_Community_Wishlist_Survey

The Wishlist Survey voting phase lasts until Dec 14th. After the voting has concluded, the top proposals will form the backlog for the Community Tech team to investigate and address.

See also T8948: Natural number sorting in category listings, which may overlap/duplicate.

Proposal:

Names containing numerals (or with numeric sort-keys) are presently sorted in alphabetical/ASCII order, apparently being treated like any other character: for example “100” comes before “17” but after “10”. This makes a mess of categories for things with serial numbers, like asteroids and street addresses, unless they’re given sort-keys with zero-padded numbers—very tedious. Would it be possible to parse names for sorting by reading any consecutive numerals as digits of a decimal number, instead of just character-by-character, so as to sort by numeric value instead? Even my antique Mac’s Finder does something like this with file and directory names, so it can’t be that hard! ;)

Odysseus1479 (talk) 05:12, 18 November 2015 (UTC)

https://meta.wikimedia.org/wiki/2015_Community_Wishlist_Survey/Categories#Numerical_sorting

Event Timeline

DannyH created this task.Dec 4 2015, 10:15 PM
DannyH raised the priority of this task from to Needs Triage.
DannyH updated the task description. (Show Details)
DannyH moved this task to Wishlist 51-on on the Community-Wishlist-Survey-2015 board.
DannyH added a subscriber: DannyH.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptDec 4 2015, 10:15 PM
TTO added a subscriber: TTO.Dec 5 2015, 3:39 AM

Definitely a dupe of T8948. I'll leave it to Community Tech to merge if they want to, though.

DannyH closed this task as Resolved.Dec 7 2015, 9:58 PM
DannyH claimed this task.

Okay, I'll close this and use the other ticket instead. Thanks

DannyH set Security to None.
DannyH moved this task from Untriaged to Archive on the Community-Tech board.Dec 8 2015, 6:54 PM