Page MenuHomePhabricator

Some revisions don't load in wikilabels -- old revision info remains.
Closed, ResolvedPublic

Description

From @Woodcutterty

Reporting a possible bug: every now and then, a piece of the workset appears to contain no separate revision. Instead it shows the previously selected revision. Example:

This is the 36th revision shown in a workset: https://gyazo.com/8ae1d9d1ff53cbe2b7c25614d06ddc9b
When I select the 37th revision, I see the same one: https://gyazo.com/f5ca72fafdc8b283f50a51a502053b48
This is the 38th revision in that same workset: https://gyazo.com/9373d47bd1ca0ef97536d1558ce4df94
Now when I select the 37th again, I see that revision: https://gyazo.com/29ef4a9885d65f6df8be0b47c63f7d0e

I mark these seemingly empty revisions as 'Unsure?'.

Event Timeline

Halfak created this task.Jan 4 2016, 5:47 PM
Halfak raised the priority of this task from to Needs Triage.
Halfak updated the task description. (Show Details)
Halfak moved this task to Active on the Scoring-platform-team (Current) board.
Halfak added subscribers: Halfak, Jeroen_N.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptJan 4 2016, 5:48 PM

@Woodcutterty, could you help me work out what rev_ids appear in these worksets with problematic revisions? Any rev_id that appears in the workset will help me zero in on the issue.

Just realized that I can see the rev_ids in your screenshots. I'll work with those.

I collected some additionals ones anyway. Figured two id's is probably not a lot to work with.

43869667 - 42942361
44671657 - 42873321
42224678 - 44482225
44630436 - 44195345
43025773 - 44014757
44503664 - 44889391

Every set is the rev_id appearing before and after the one that doesn't load, respectively.

Halfak added a comment.EditedJan 14 2016, 1:25 AM

OK. I made some progress. It looks like the problem is that the parent revision was revdeleted. When this happens the API responds in a weird way.

So, we need to handle this weirdness.

Edit

Here's a paste of the API response:

{
   "batchcomplete":"",
   "warnings":{
      "revisions":{
         "*":"Couldn't diff to r43712057: content is hidden"
      }
   },
   "query":{
      "pages":{
         "298194":{
            "pageid":298194,
            "ns":0,
            "title":"Wereldrecord",
            "revisions":[
               {
                  "revid":41562896,
                  "parentid":41562818,
                  "minor":"",
                  "user":"Kleuske",
                  "timestamp":"2014-06-25T07:35:57Z",
                  "comment":"Wijzigingen door [[Special:Contributions/88.159.163.99|88.159.163.99]] ([[User talk:88.159.163.99|Overleg]]) hersteld tot de laatste versie door [[User:FakirNL|FakirNL]]"
               }
            ]
         }
      }
   }
}

Fixed in https://github.com/wiki-ai/wikilabels/commit/79b0cada2d460d795428a66b95026866ce4794f8

Thanks again for reporting. We should have this deployed tomorrow. :)

This is now deployed. @Woodcutterty, could you check to see if those revisions load now? You should get an error message that says "No difference" or the dutch equivalent "Geen verschil"

It's working. I'm getting the error message 'Geen verschil' and I can see that the revision was hidden. Thanks again :)

I'm assuming it doesn't really matter how these revisions are labelled? I'm labelling them 'unsure', but I can imagine some users will mark them as damaging and not done in good faith, because "why else would the revision have been hidden".

Indeed. As a matter of practice, it doesn't matter how they are labeled, but it might help if you make sure to make them "unsure". When we use this data to build prediction models, we won't be able to use the deleted revisions anyway.

Halfak claimed this task.Jan 15 2016, 5:55 PM
Halfak set Security to None.

Seems like it would be.

Halfak closed this task as Resolved.Jan 21 2016, 3:43 PM